index

Live Performance Pro V2

Описание программы Live Performznce Pro V2

Программа Live Performznce Pro (в дальнейшем - LPPro) - это специализированный проигрыватель аудио файлов, имеющий широкие возможности работы со списками воспроизведения. Программа Lppro специально "заточена" для использования ее музыкантами, работающими под "минусовки", для театров, клубов и дискотек. Программа может служить в качестве домашнего аудиопроигрывателя.

Отличия Lppro V2 от предыдущих версий.

Что нового в Lppro V2:

Новый MDI интерфейс. Неограниченное количество одновременно открытых списков воспроизведения.

Возможность создания файла текста песни (Lyriks) и синхронный показ текста песни во время воспроизведения.

Наличие отдельного проигрывателя "фоновой" музыки. Проигрыватель фоновой музыки имеет режим работы автоматического заполнения пауз.

Усовершенствованный проигрыватель подслушки, являющийся одновременно файловым менеджером. Имеет возможность запоминания часто используемых папок (фавориты), фильтрацию по типам и именам файлов, функции копирования и удаления файлов.

Более надежный аудиодвижок с возможностью редактирования огибающей кроссфейда.

Возможность работы с тремя отдельными аудиоустройствами. (Основное устройство, устройство канала подслушки, устройство канала фоновой музыки).

Воспроизведение файлов *.wav, *.mp3, *.ape, *.wma, *.ogg. (Для воспроизведения файлов *.ape, *.wma, *.ogg необходимо скачать и установить набор соответствующих кодеков)

Вот список ссылок для загрузки набора кодеков K-Lite codec pack:

http://a1.edskes.com/k/klcodec234f.exe
http://c2.edskes.com/klcodec234f.exe
http://e7.edskes.com/klcodec234f.exe
http://e8.edskes.com/klcodec234f.exe
ftp://217.11.135.34/pub/Multimedia/DivX-codecs/klcodec234f.exe
ftp://193.219.76.7/pub/Windows/audio/K-Lite/klcodec234f.exe
ftp://80.51.143.5/pub/Windows/Progs/kodeki/klcodec234f.exe
ftp://211.109.0.89/download/KLite_CodecPack/2.34/klcodec234f.exe

Возможность сохранения всего текущего состояния программы (открытые списки, расположение окон, все настройки программы и т.д.) в специальном файле Перфоманса (performance). Вы можете создать перфомансы на "все случаи жизни и работы" и загружая нужный перфоманс моментально подготавливать программу к работе.

При выходе из программы сохраняется ее состояние на момент закрытия, включая открытые списки и текущие песни в списках. При последующем старте программы состояние восстанавливается. Для восстановления списков при запуске программы не закрывайте списки пред выходом.

Теперь программа автоматически помечает проигранные в текущей сесии файлы (поле "Статуса").

"Прертаскивание" мышкой файлов между основными окнами программы (производится при нажатой клавише Ctrl)

Lppro V2 не является усовершенствованием Lppro V1.xx. Программа Lppro V2 Написана полностью "с нуля".

Чего нет в Lppro V2 по сравнению с Lppro V1.xx

Удален дополнительный список "Aside".
Не реализована функция избранных списков (Слот).
решено, что надобность в этих двух функциях отпала с появлением MDI интерфейса (неограниченного количества списков) и механизма сохранения - загрузки перфомансов.
Не реализована возможность установки паузы между песнями - будет в следующих версиях.

!!!Ограничения:

В текущей версии не поддерживается использование mp3 файлов, сжатых с переменным битрейтом. Файлы будут воспроизводиться, но механизм кроссфейда будет работать некорректно. Также не гарантируется правильное определение времени звучания mp3 файлов с переменным битрейтом.

Требования к системе

Программа работает в среде Microsoft Windows 98/ME/ 2000/XP.

Минимальная конфигурация:

Процессор - не хуже Pentium Pro c тактовой частотой 233 мГц.
Оперативная память - не менее 64 мб.
Звуковая плата - Direct X совместимое звуковое устройство.
Видеосистема - 800*600, 16 бит цвет.
DitrectX 8

Рекомендуемая конфигурация:

Процессор - Pentium III 450 мГц или выше.
Оперативная память - 128 мб или болше.
Звуковая плата - По крайней мере, не хуже SB Live! в качестве основного устройства. Рекомендуется наличие дополнительной звуковой карты с выходом на наушники - для устройства подслушки. (При использовании карты семейства SBLive!/Audigi рекомендуется установка драйверов от KX Project. В этом случае вы получаете возможность использовать фронтальные и тыловые выхода как различные звуковые устройства. При этом логично использовать тыловые выхода (как более качественные) в качестве устройства основного канала, а фронтальные (как более мощные) - для подключения наушников). Пользователям ноутбуков мы рекомендуем установить звуковую карту Indigo i/o или Indigo dj. При этом встроенную карту ноутбука можно использовать на канале подслушки и подключить туда наушники.
Операционная система - рекомендуется WindowsXP professional SP2.
Видеосистема - для комфортной работы - 1024*768, 16 бит цвет.
DitrectX 8.1.


licence

Лицензионное соглашение на право использования Live Perfomance Pro

Пожалуйста, тщательно изучите этот документ перед использованием данного программного продукта. Если Вы не согласны с чем-либо из написанного ниже, Вам не разрешается использовать эту программу. Вы ДОЛЖНЫ немедленно удалить ее.

Shareware-версия

Вы имеете право тестировать эту программу в течение 30 часов ee непрерывной работы, но не более 30 дней. Вам разрешается копировать эту Shareware-версию (и ТОЛЬКО Shareware-версию) и передавать ее любому другому лицу при условии, что она не модифицируется никаким образом. Под модификацией понимается изменение, добавление или удаление любых файлов из настоящего архива без письменного разрешения авторов. Вам НЕ разрешается распространять эту программу вместе с каким-либо коммерческим программным обеспечением или печатным изданием. Разрешается располагать эту программу на любом возможном количестве электронных досок объявлений, FTP-сайтов и т.п. Распространение программы на компакт-дисках (CD-ROM) также допускается при условии неизменности оригинального архива. Использование этого программного обеспечения после 30-дневного пробного периода является нарушением международного законодательства об авторских правах. Это также некорректно по отношению к авторам, которые потратили сотни часов своего времени, разрабатывая программу.

Регистрация

Программа не является ни распространяемой бесплатно (freeware), ни общественным достоянием (public domain). Использование программы в течение более 30 дней требует регистрации. Ознакомьтесь на странице http://www.lppro.narod.ru/ со стоимостью лицензии.

Зарегистрированная версия

(персональная лицензия) Зарегистрированная версия может быть установлена на ЕДИНСТВЕННЫЙ компьютер. Использование программы на нескольких компьютерах даже одним и тем же лицом требует дополнительных лицензий.

Ответственность

Мы пытаемся освобождать наше программное обеспечение от ошибок в той мере, в которой это возможно. Однако существует общее правило, что не существует программ, полностью свободных от ошибок, и число ошибок растет с увеличением сложности программы. Поэтому мы не можем гарантировать, что это программное обеспечение будет функционировать без каких бы то ни было ошибок в любом окружении, на любом компьютере, где установлены Windows, вместе с любым другим установленным программным обеспечением. Любая ответственность за любой вред, нанесенный программой, отвергается. В любом случае, ответственность ограничивается стоимостью регистрации. Пожалуйста, тестируйте эту программу с некритическими данными. Мы не можем гарантировать безопасность Ваших данных. Если Вы обнаружили ошибки до регистрации и, тем не менее, зарегистрировали программу, это означает, что Вы смирились с ними. Любые указания на ошибки будут приниматься нами, но мы не можем гарантировать, что мы сможем исправитть их.


support

Регистрация и поддержка

Live Performance Pro - это не бесплатная программа, вам дается некоторое время для ее испытания. Данная верстия программы -ознакомительная. Это - полнофункциональная верся, иеющая, однако, следующие ограничения:

- 1. Время неперерывной работы программы составляет 30 часов. Это означает, что работая с программой 1 час в день, вы сможете использовать ее в течение 30 дней и т.д. По истечение этого периода времени программа потребует регистрации.

- 2. Каждые 2 минуты работы программы выводится окно сообщения, напоминающее о том, что это демо-версия. (вывод этого окна не влияет на процесс воспроизведения музыки).

По истечении ознакомительного периода работы вы должны зарегистрировать Live Performance Pro , либо отказаться от дальнейшего ее использования . Для регистрации необходимо оплатить стоимость программы.

Если вам понравилась программа и вы хотите, чтобы она развивалась, пожалуйста зарегистрируйтесь. Это даст нам средства на дальнейшее ее улучшение.
Если у вас возникли вопросы по регистрации, то пишите: lppro@narod.ru

Зарегистрированные пользователи могут бесплатно пользоваться службой поддержки, и получать новые версии бесплатно или со значительной скидкой. Если у вас возникли вопросы по использованию Live Performance Pro , то пишите: lppro@narod.ru Если у вас появились идеи или пожелания по улучшению Live Performance Pro , напишите нам о них lppro@narod.ru. Эти идеи и пожелания будут по возможности реализованы в новых версиях. Информацию о новых версиях программы можно получить на нашем сайте:

http://www.lppro.narod.ru


start

Начало работы с Live Performance Pro

Первый запуск программы.

Создание списков воспроизведения. Сохранение, загрузка и импорт списков.

Воспроизведение музыки .

Фоновый проигрыватель.

Проигрыватель подслушки.

Работа с текстами песен (Lyriks).

Настройка параметров программы.

Первый запуск.

После установки Lppro на Вашем рабочем столе должен появиться ярлык Lppro:

Запустите программу двойным щелчком мыши на этом ярлыке.

До тех пор пока вы не зарегисирируете программу она будет стартовать в демонстрационном режиме. При этом перед запуском программы будет выдаваться сообщение том, что это демонстрационная версия программы и оставшееся время ее непрерывной работы:

Для продолжения работы с программой нажмите кнопку OK.

Установка языка программы.

По умолчанию язык программы - английский. Для того, чтобы установить русский язык, в главном меню программы выберите Language и потом Russian. Язык интерфейса программы поменяется на русский.

Регистрация программы и снятие ограничений.

Для регистрации программы и снятия ограничений демо-версии в главном меню выберите:

Справка [image] Регистрация...

 Запустится программа регистрации. Введите имя пользователя, регистрационный код и серийный номер. Затем нажмите кнопку OK.

Если вы правильно ввели регистрационную информацию, то через несколько секунд программа сообщит вам, что ограничения сняты. В противном случае вам будет предложено ввести информацию еще раз.

Обращаем ваше внимание на то, что имя пользователя и регистрационный код нужно вводить именно так, как вы их получили - с учетом регистра букв. Если имя пользователя состоит из нескольких слов, то между ними должен быть ОДИН пробел.

Перезапустите Lppro.


Untitled Document

Работа с Перфомансами в LPPro.

В любой момент работы с LPPro вы имеете возможность сохранить текущее состояние программы в виде файла на диске. Файл рабочего пространства программы, или Перфоманс имеет расширение *.lpp (LPPro Pepformance).

Вы можете создать файлы перфомансов, в которых сохраните настройки программы для разных вариантов вашей работы. К примеру, для озвучивания дискотеки вам необходимо 10 списков с различной музыкой. Вы обычным образом открываете нужные списки, а потом сохраняете перфоманс в файле с именем diskoteka1.lpp. На следующий день вы запускаете программу и просто открываете файл перфоманса diskoteka1.lpp. Открываются все списки, которые были открыты на момент сохранения файла перфоманса. Вам уже не нужно открывать отдельно каждый список.

Внимание! для того, чтобы список был загружен при открытии файла префоманса, список должен быть СОХРАНЕН! Инми словами, если вы создали новый список и добавили в него строки, то перед тем, как сохранить состояние программы в перфомансе, необходимо сохранить список.

В файле Перфоманса сохраняется (и восстанавливается при загрузке) следующая информация:

Расположение и размер главного окна программы.

Открытые на момент сохранения Перфоманса списки воспроизведения (файлы списков должны присутствовать на диске, то есть списки должны быть сохранены).

жение и размеры окон открытых списков воспроизведения.

Позиция курсора (текущая песня) в каждом списке.

Все настройки программы (см. окно настроек>>)

Расположение, размеры и видимость окон микшера, кармана, фонового проигрывателя, подслушки-файлового браузера.

Сохранить рабочее пространство программы как Перфоманс можно несколькими способами:

1. В главном меню программы выбрать Файл1 [image] Сохранить перфоманс. Или:

2. На клавиатуре нажать сочетание Alt+S. Или:

3. На панели инструментов главного окна нажать кнопку [image].

В появившемся диалоговом окне сохранения задайте папку и имя файла перфоманса, потом нажмите Save ("Сохранить").

Загрузить рабочее пространство программы из Перфоманса можно несколькими способами:

1. В главном меню программы выбрать Файл1 [image] Загрузить перфоманс. Или:

2. На клавиатуре нажать сочетание Alt+O. Или:

3. На панели инструментов главного окна нажать кнопку [image].

В появившемся диалоговом окне выберите папку и имя файла перфоманса, потом нажмите Open ("Открыть").


tut_play

Начало работы - воспроизведение музыки

Поддерживаемые звуковые форматы.

Связывание звуковых файлов с Lppro.

Воспроизведение из проводника Windows.

Воспроизведение из списка.

Регулирование громкости в процессе воспроизведения из списка.

Использование подслушки.

Воспроизведение в фоновом проигрывателе.

Поддерживаемые звуковые форматы .

Программа Lppro поддерживает несколько форматов звуковых файлов:

- Несжатое аудио: Microsoft PCM Wave File - *.wav

- Сжатый звуковой файл - Mpeg 1 layer 3 - *.mp3

- Сжатый звуковой файл - Microsoft Windows Media Audio - *.wma

- Сжатый звуковой файл - OGG Worbis - *.ogg

- Сжатый без потери качества звуковой файл - Monkey Audio APE - *.ape

Программа Lppro использует для воспроизведения и микширования звука систему Microsoft DirectX. Для воспроизведения любых звуковых файлов, отличных от WAV необходимо чтобы в системе был установлен декодер этих форматов (ACM - Audio Compression Management - система управления сжатым аудио). В Windows 98se/ME/2000/XP без проблем должны влспроизводиться файлы типа WAV и MP3. Для файлов WMA, OGG, APE необходимо скачать и установить соответствующий ACM-декодер. Скачать набор декодеров для поддержки всех форматов аудиофайлов можно на сайте поддержки http://www.lppro.narod.ru в разделе загрузки файлов.

Связывание звуковых файлов с Lppro (рекомендуется!).

Программа установки Lppro не связывает автоматически расширения файлов с Lppto. Если вы хотите, чтобы звуковые файлы типа mp3, wma, ogg, ape, wav открывались в для прослушивания в Lppro из проводника Windows, то вы должны сами это сдедать. Для того, чтобы связать указанные типы файлов с Lppro.
Для этого нажмите F5, чтобы открыть окно настроек программы. На вкладке "Разное 1" нажмите кнопку "Связать файлы с Lppro". Появится запрос "Вы уверены?", нажмите кнопку "Yes". В результате файлы wav, mp3, wma, ogg, ape, а также файлы списков lpl будут связаны с Lppro.
Подробнее см. в разделе Настройки программы.

Воспроизведение из проводника Windows.

Если вы связали звуковые файлы с Lppro, то теперь дваджды щелкнув по файлу в проводнике Widows вы запустите его воспроизведение в Lppro. В этом случае файл всегда будет воспроизводиться в проигрывателе подслушки.

Воспроизведение из списка.

Как только вы создали список воспроизведения и добавили туда записи, вы можете начать проигрывать музыку из списка.

Lppro поддерживает работу с тремя независимыми звуковыми устройствами (звуковыми картами или многоканальными звуковыми интерфейсами). Наиболее качественоое устройство целесообразно использовать в качестве основного, то есть того, через которое воспроизводится музыка из списка воспроизведения (устройство виртуального микшера). Песни из списка воспроизведения проигрываются через виртуальный микшер, который обеспечивает алгоритм поочередного воспроизведения для реализации алгоритма кроссфейда или плавного перехода одной песни в другую и других режимов воспроизведения. виртуальный микшер имеетдва канала, которые при воспроизведении по списку работают поочередно. Сначала песня загружается в один канал микшера и воспроизводится в нем. Следующая песня воспроизводится во втором канале микшера, и так далее. Вы можете установить желаемое время кроссфейда или отключить кроссфейд в окне настроек программы. Вы также можете отредактировать огибающую, то есть закон, по которому изменяется громкость во время кроссфейда в редакторе огибающей кроссфейда.

Та строка в списке, которая выделена курсором, назвается текущей строкой, текущей записью или текущей песней. Перемещать курсор по списку вверх и вниз можно клавишами стрелок на клавиатуре, либо мышкой - щелкая по нужной строке одинарным щелчком.

Для того, чтобы начать воспроизведение из списка, существует несколько способов:

1. Дважды щелкните мышкой на желаемой строке списка. Начнется воспроизведение соответствующего звукового файла.

2. На инструментальной панели главного окна программы нажмите кнопку [image] . Начнется воспроизведение текущей песни, то есть песни, строка которой в списке выделена курсором.

3. Нажать на клавиатуре сочетание "Shift+Enter" - запустится воспроизведение. остановить воспроизведение можно нажав на клавиатуре "Shift+Spase" (Space - это клавиша пробела).

4. Выбрать в главном меню опцию Команды [image] Проиграть текущую песню

5. Управлять воспроизведением можно также из окна виртуального микшера. Подробно см. в соответствующем разделе>>.

При воспроизведении музыки по списку очередная песня загружается в микшер и начинает воспроизводиться. Та песня строка которой расположена ниже текущей, автоматически становится СЛЕДУЮЩЕЙ (Next) в порядке воспроизведения. При окончании воспроизведения текущей песни начинает проигрываться следующая, она становится текущей, и так далее. Название Следующей песни выводится в небольшом окошке на инструментальной панели главного окна программы:

- кнопочка и окошко следующей песни .

Вы можете в любой момент изменить последовательность воспроизведения, выделив какую-либо строку в списке и потом нажав кнопочук Next, расположенную слева от окошка Следующей песни (см рисунок выше). При этом выделенная песня станет следующей и ее воспроизведение начнется после того, как закончится воспроизведение текущей песни. Сделать песню следующей можно также просто перетащив ее мышкой из списка на окшко следующей песни, показанное на рисунку выше. Напоминаем, что любое перетаскивание из списка воспроизведения производится с нажатием и клавиши Ctrl.

Запустить на воспроизведение Следующую песню, не дожидаясь окончания предыдущей, можно нажав кнопочку [image] на инструментальной панели главного окна, либо выбрав в главном меню опцию Команды [image] Проиграть следующую

Во время воспроизведения на панели инструментов отображается, прошедшее с начала воспроизведения песни, либо время, оставшееся до конца воспроизведения. переключаться между этими режимами можно щелкая мышкой на индикаторе времени одного из каналов:
- дисплей времени.

Полоска индикатора времени визуально показывает позицию времени воспроизведения песни. Вы можете быстро перейти к желаемому участку фонограммы, щелкнув мышкой на соответствующем участке полоски:
- Полоска времени.

Регулирование громкости в процессе воспроизведения из списка.

Виртуальный микшер основного устройства Lppro имеет три регулятора громкости. Два из них - это регуляторы громкости каналов микшера, и один - регулятор общей громкости основного устройства. Если вы откроете окно Виртуального микшера (клавиша "Пробел"), то вы сможете отдельно устанавливать громкость первого и второго каналов. Находясь в главном окне программы вы можете изменять только общую громкость, которая воздействует в одинаковой степени на оба канала. Регулятор общей громкости - это синяя полоска, которая находится в правой части главного окна программы:

максимальная громкость - 100 едениц. Вы можете изменять громкость с клавиатуры шагами по 2 еденицы, нажимая клавиши < и > или на дополнительной клавиатуре клавиши + и -

Если включен режим Громкость из Списка, то при начале воспроизведения песни громкость того канала, в котором она воспроизводится будет автоматически установлена в соответствии с тем значением, которое вы задали в списке воспроизведения. Включить режим Громкость из Списка можно в окне настроек программы. Подробнее о том, как установить громкость индивидуально для каждой песни см. в разделе Редактирование строки списка.

Использование подслушки.

Как известно, Lppro может работать с несколькими звуковыми устройствами. Вы можете крутить дискотеку через основное устройство и одновременно выбирать файлы на жестком диске, составлять списки воспроизведения, прослушивать песни из списков через наушники, подключенные к другой звуковой карте. Для этого существует окно проигрывателя подслушки. Это окно является многофункциональным, очень удобным в работе инструментом. Проигрыватель подслушки совмещен с небольшим файловым браузером, в которм вы можете листатбь папки, копировать и удалять файлы, открывать списки воспроизведения, добавлять файлы в списки, и даже запускать другие программы. Подробно обо всех функциях данногог окна вы можете прочитать в разделе Окно проигрывателя подслушки и файлового браузера.

Для того, чтобы проиграть файл списка через подслушку, а не через основное устройство, в главном меню программы выберите пункт Команды [image] Проиграть в подслушке. Песня загрузится в проигрыватель подслушки и начнется ее воспроизведение. При этом в окне файлового браузера откроется папка, в которой находится файл на жестком диске, а курсор окна файлов установится на проигрываемый файл.
Того же эффекта можно добиться, просто перетащив песню из списка на окно проигрывателя подслушки, если оно открыто. Также можно нажать кнопку [image] На инструментальной панели главного окна программы, либо нажав сочетание клавиш "Shift+F7" (самый быстрый способ).

Воспроизведение в фоновом проигрывателе.

Кроме виртуального микшера и проигрывателя подслушки, в Lppro есть еще один проигрыватель, который может быть назначен на отдельное звуковое устройство. Это - проигрыватель фоновой музыки. Задуман он был для заполенния фоновой музыкой пауз в работе основного устройства. Если вы останавливаете основное устройство, то включается фоновая музыка. Когда вы снова запускаете воспроизведение из списка, то сначала плавно выводится громкость фоновой музыки, и только потом включается воспроизведение песни из списка. Подробно о том как работает фоновый проигрыватель можно почитать в разделе "Проигрыватель фоновой музыки". Здесь мы отметим только то, что в фоновый проигрыватель может быть загружен любой ранее сохраненный на диск список Lppro. Списки можно также создавать и сохранять в самом фоновом проигрывателе, и поддерживается перетаскивание мышкой информации из списка воспроизведения в список фонового проигрывателя (но не наоборот!).
Чтобы открыть окно фонового проигрывателя, в главном меню программы выберите пункт Показать... Фоновый проигрыватель. Также можно нажать кнопку [image] На инструментальной панели главного окна программы, либо на клавиатуре нажать клавишу "F8"


tut_lists

Начало работы - Создание списков воспроизведения. Сохранение, загрузка и импорт списков.

Списки воспроизведения в Lppro V2. Структура списка

Создание списков и добавление файлов

Сохранение списка

Загрузка списка

Импорт списка формата Lppro 1.xx

Структура списка в Lppro 2.0.

Список Воспроизведения состоит из строк, в которых хранится информация о звуковом файле, находящемся на жестком диске компьютера. Такая строка списка назвается Записью. Строка разделена на несколько частей - столбцов. В каждом столбце хранится определенная информация о звуковом файле. Такой столбец называется Полем. В списке воспроизведения Lppro V2.0 существуют следующие поля:

- # - в этом поле хранится порядковый номер песни. Это "ключевое поле". За это поле вы можете перетаскивать мышкой строки вверх и вниз по списку, тем самым изменяя порядок следования песен.

- S - это поле статуса. Оно имеет только два состояния: отмеченное (*) или установленное и неотмеченное . Поле статуса играет важную роль в программе. Во-первых, оно показвает, что песня уже была проиграна в текущем сеансе работы со списком. Во-вторых многие групповые операции со строками списка обрабатывают только строки с установленным полем статуса для выборочной обработки записей.

- Имя файла - в этом поле хранится имя файла, под которым данный файл существует на вашем жестком диске. На самом деле в списке хранитьтся имя файла вместе с полным путем к нему, но на экран выводится только имя файла. Для того, чтобы посмотреть путь к файлу нажмите клавишу 'i' на клавиатуре. Будет выведено окно с информацией о файле.

- Темп - в этом поле хранится информация о темпе песни (в ударах в минуту - BPM). При добавлении файла в список темп по умолчанию устанавливается равным 120 bpm. Если в список добавляется ссылка на mp3-файл, то программа пытается извлечь информацию о темпе из id3 - тэга 'Track'. Если информация не найдена, то устанавливается темп 120 bpm. Вы можете изменить значение темпа в специальном редакторе, введя нужное значение, либо нажимая на клавишу "Пробел" в такт с проигрываемой музыкой. Подробнее см. "редактирование строки списка"

- Название - в этом поле хранится название песни. При добавлении файла в список программа пытается извлечь информацию о названии из id3 - тэга "Titlle". Если информация не найдена, то в это поле заносится имя файла. вы можете изменить поле названия песни, введя любой другой текст. Подробнее см. "редактирование строки списка".

- Исполнитель - в этом поле хранится информация об исполнителе. При добавлении файла в список программа пытается извлечь информацию о названии из id3 - тэга "Artist". Если информация не найдена, то в это поле остается пустым. Вы можете изменить поле Исполнителя, введя любой другой текст. Подробнее см. "редактирование строки списка".

- Время - в этом поле хранится длительность песни в формате "Часы:Минуты:Секунды". Поле заполняется автоматически при добавтениии файла в список. Вы не можете изменить информацию в этом поле.

Скрытые поля - в списке существуют скрытые поля - то есть поля, которые не отображаются в таблице, но хранятся в файле списка и в памяти компьютера. Скрытые поля доступны для просмотра и изменения при редактировании строки списка. Подробнее см. "редактирование строки списка". Ниже перечислены скрытые поля:

- Предустановка громкости - в этом поле хранится предустановка громкости песни. В программе имеется режим воспроизведения, при котором значение громкости песни берется из списка воспроизведения. Это означает, что вы можете установить для каждой отдельной песни громкость, с которой она будет воспроизводиться. Минимальной громкости соответствует значение '0', максимальной - '100'. Подробнее см. "редактирование строки списка".

- Предустановка времени кроссфейда - в этом поле хранится предустановка времени кроссфейда (плавного перехода от одной песни к другой) индивидуально для каждой песни. В программе имеется режим воспроизведения, при котором значение времени кроссфейда берется из списка воспроизведения. Это означает, что вы можете установить время кроссфейда для каждой отдельной песни. Время кроссфейда устанавливается в секундах. Подробнее см. "редактирование строки списка".

- Предустановка времени паузы - в данной версии программы не используется. Зарезервировано для будущих версий.

В отличие от Lppro V1, в которой можно было оработать только с одним основным списком воспроизведения, программа Lppro V2.0 позволяет одновременно работать с неограниченным количеством списков (Количество одновременно открытых списков ограничено только ресурсами вашего компьютера).

В программе Lppro V1 списки хранились в файлах с расширением *.lst. В Lppro V2.0 применяется другой формат файла. Файл имеет расширение *.lpl. Вместе с файлом *.lpl создается одноименный файл с расширением *.lpf в котором сохраняются такие парметры списка, как цвет и размер шрифта, цвет фона, размер и расположение окна списка, и т.д. Имеется возможность импорта списка старого формата (lpproV1.xx).

Независимо от того, сколько списков открыто, один из них всегда является АКТИВНЫМ или ТЕКУЩИМ . Активный список - это тот, с которым вы работаете в данный момент. Его окно всегда распологается поверх окон других списков.

Список, который проигрывается в данный момент времени называется ЗВУЧАЩИМ. Звучащий список - НЕ обязательно Активный. Вы можете воспроизводить музыку из одного списка (он Звучащий) и в то же время редактировать другой список (он будет Активным или Текущим).

Для того, чтобы быстро перейти к Звучащему списку, то есть сделать его Активным, нажмите клавишу F9 или выберите в главном меню прогаммы опцию Показать [image] Перейти к звучащему списку.

Создание списка и добавление файлов

Для того, чтобы создать новый список воспроизведения существует несколько путей.

В лавном меню прогаммы выберите опцию Файл1 [image] Новый Список. Будет создано окно пустого списка и списку будет присвоено имя, состоящее из слова List и порядкового номера плюс расширение файла (.lpl), Например, "List1.lpl", "List5.lpl". Для того, чтобы изменить имя файла списка сохраните его под другим именем.

Создать пустой список можно также щелчком мышки на кнопке [image] на инструментальной панели главного окна программы, либо нажав на клавиатуре сочетание клавиш Ctrl+N

Добавление файлов в список. После того, как создан пустой список вы должны добавить в него строки - ссылки на звуковые файлы, находящиеся на вашем жестком диске. Добавлять информацию в список воспроизведения можно несколькими способами. В любом случае информация добавляется в Активный (Текущий) список. Далее перечислены способы, которыми можно добавить в список новые строки (записи):

Способ 1:Добавление одного или нескольких файлов из какой-либо папки. В лавном меню прогаммы опцию Файл1 [image] Добавить файлы, либо щелкните мышкой на кнопке [image] на инструментальной панели главного окна программы, либо просто нажмите на клавиатуре клавишу A. Появится стандартный диалог открытия файлов Windows. Найдите нужную папку со звуковыми файлами. Выделите один или несколько файлов (несколько файлов можно выделять, щелкая на файлах мышкой и удерживая при этом нажатой клавишу Ctrl) и щелкните на кнопке Open. Файлы будут добавлены в список воспроизведения.

Способ 2: Поиск и добавление файлов, сканирование папок. При использовании этой функции вы задаете корневую папку и маску файла. Программа осуществит сканирование всех вложенных папок и добавит все найденные файлы с заданными вами параметрами. Например вы можете добавить в список ВСЕ файлы с расширением *.wav, которые имеются на вышем диске 'С:\'. Для того, чтобы вызвать функцию сканирования папок, В главном меню прогаммы выберите опцию Файл1 [image] Сканировать папки и добавить файлы (поиск)... Можно вызвать эту функцию нажав сочетание клавиш 'Ctrl+T', либо щелчком мышки на кнопке [image] на инструментальной панели главного окна программы. (Подробно см. "Окно сканирования и поиска")

Способ 3: Добавление перетаскиванием мышкой из окна подслушки/файлового браузера . В программе есть специальное окно файлового браузера, совмещенного с проигрывателем подслушки. Вэтом окне вы можете перемещаться по дискам и папкам вашего компьютера и прослушивать звуковые файлы через устройство подслушки. Вы можете добавлять файлы в список воспроизведения простым перетаскиванием их мышкой из этого окна в окно списка. Для того, чтобы открыть окно подслушки/файлового браузера на клавиатуре нажмите клавишу 'F7'. Другой способ - в главном меню прогаммы выберите опцию Показать [image] Подслушку и файловый браузер, либо либо щелкните мышкой на кнопке [image] на инструментальной панели главного окна программы (Подробно см. "Окно проигрывателя подслушки и файлового браузера ").

Способ 4:Добавление перетаскиванием мышкой из другого списка. Вы можете добавлять строки в список, перетаскивая их мышкой из другого открытого списка. Перетаскивание осуществляется при нажатой клавише Ctrl.

Способ 5: Добавление записей копированием в карман и вставкой из кармана. "Карман" в Lppro - это специальный дополнительный список, который является буфером для копирования и вставки строк списков, наподобие буфера обмена Windows. Подробнее с функциями кармана можно ознакомиться в разделе Окно кармана. Окно кармана может быть видимо, или не видимо на экране. Независимо от этого вы можете обмениваться с карманам информацией. Для того, чтобы скопировать одну или несколько строк списка в карман, выделите строки и нажмите 'Ctrl+C'. Текущая строка (или несколько выделенных строк) будут скопированы в карман. Для того, чтобы вставить в список информацию из кармана, выделите строку в позицтю которой (или ниже которой - в зависимости от настроек кармана) вы хотите вставить строки из кармана. Затем нажмите 'Ctrl+V'. Информация будет вставлена. Вы можете вставлять информацию в тот же список, из которого вы копировали, или в любой другой открытый список. Если окно кармана в данный момент видимо, то вы можете пертаскивать мышкой файлы из списка в карман ир из кармана в любой открытый список. Операции перетаскивания мышью из списка воспроизведения осуществляются при нажатой клавише Ctrl. Чтобы открыть окно кармана нажмите на клавиатуре клавишу F10, либо щелкните мышкой на кнопке [image] на инструментальной панели главного окна программы. Можно также главном меню прогpаммы выберать опцию Показать... Карман.

Способ 6: Добавление записей перетаскиванием файлов из проводника Windows или из внешнего файлового менеджера (например Windows Commander). Приемником файлов при перетаскивании их из проводника Windows могут служить следующие окна Lppro:
1. Главное окно программы.
2. Окна списков воспроизведения.
3. Окно проигрывателя подслушки/файлового браузера.

При добавлении файлов этим способом удобно переключить прогамму в компактный режим, при этом главное окно и все окна открытых списков становятся невидимыми и на экране остается только окно проигрывателя подслушки. Для переключения программы в компактный режим и обратно в полный режим нажимайте на клавиатуре клавишу F11. на инструментальной панели главного окна программы для перехода в компактный режим предусмотрена кнопка [image]. Точно такая же кнопка есть и на панели окна подслушки.

Сохранение Списка Воспроизведения на жестком диске.

Список, который вы видите на экране вашего монитора находится в оперативной памяти компьютера. Если вы вносите какие-либо изменения (добавляете или удаляете строки, изменяете информацию), то для того, чтобы сохранить результаты вашей работы, необходимо записать ваш список на жесткий диск в виде файла. Иначе при закрытии программы или при отключении питания результаты работы будут потеряны. В программе Lppro V2 списки хранятся в файлах с расширением *.lpl.

Когда вы создаете новый список, то программа автоматически присваивает ему некоторое имя, состоящее из слова list и цифры, Например:"List1.lpl", "List5.lpl". При создании нового списка он существует только в оперативной памяти компьютера. Если вы хотите в дальнейшем использовать этот список, вы должны сохранить его на диске в виде файла. При этом желательно задать ему какое-либо более осмысленное имя, например "jazz.lpl", "банкет1.lpl" и т.д. Для сохранения списка и задания ему нового имени служит функция "Сохранить Список с новым именем". В главном меню программы выберите опцию Файл1 [image] Сохранить Список с новым именем (На клавиатуре "Ctrl+Alt+S", или на панели инструментов главного окна кнопка [image]). Появится стандартный диалог сохранения файлов Windows. Обращаем ваше внимание на то, что если вы используете английскую версию Windows, то этот диалог будет на английском языке. Это не является ошибкой программы Lppro. Выберите пвапку, куда вы будете созранять список. При первом запуске процедуры сохранения программа предложит вам сохранить файл в свою рабочую папку. настоятельно рекомендуется выбрать другую папку, например создать специальную папку для списков, что-то вроде C:\Списки\. Далее вы можете заменить имя сохраняемого файла на то, которое вам больше нравится, после чего нажмите кнопку "Сохранить" ("Save"). Файл будет записан на жесткий диск.

После того, как вы сохранили файл на диске, вы можете и идальше вносить в список изменения, добавлять строки, редактировать поля, и т.д. Для быстрого созранения списка в этом случае служит опция Файл1 [image] Сохранить Список(На клавиатуре "Ctrl+S", или на панели инструментов главного окна кнопка [image]). Если файл списка уже был однажды сохранен (и если вы его создали ранее, а в данном сеансе работы просто загрузили с жесткого диска), то диалог сохранения файла больше не будет показан. Все изменения просто запишутся в файл списка (Если это новый список и он еще не разу небыл сохранен, то в этом случае все равно будет вызвана функция "Сохранить Список с новым именем", даже если вы выбрали просто "Сохранить Список").

Если вы внесли какие-либо изменения в список воспроизведения, то в строке состояния, расположенной внизу главного окна программы, появится слово "Modified" ("изменен"). После того, как вы сохраните список это слово исчезнет.

Если вы попытаетесь закрыть окно списка, в котором есть несохраненные изменения (либо выйти из программы Lppro), то вам будет предложено сохранить изменения. Вы можете сохранить список, закрыть окно списка или программу без сохранения изменений (тогда все изменения, сделанные со времени последнего сохранения будут потеряны), либо отказаться от закрытия списка или программы и продолжать работу (ведь вы могли случайно нажать кнопку закрытия [image]).

Загрузка Списка Воспроизведения с жесткого диска.

Способ 1: Для того чтобы загрузить (открыть) ранее сохраненный список в главном меню прогаммы выберите опцию Файл1 [image] Открыть Список ... Можно вызвать эту функцию нажав сочетание клавиш 'Ctrl+O', либо щелчком мышки на кнопке [image] на инструментальной панели главного окна программы. Появится стандартный диалог Windows, где вы можете задать путь к файлу списка и, нажав кнопку "Открыть" ("Open"), загрузить список. Вы можете открыть сразу несколько списков. Для этого удерживайте нажатой клавишу "Ctrl" и щелчком левой кнопки мышки выделите несколько списков. Для того, чтобы выделить все списки в папке нажмите "Ctrl+A".

Способ 2: Другой способ загрузить список - это двойной щелчек мышкой на файле списка в проводнике Windows. Если программа Lppro не запущена, то она запустится и список загрузится. Вы можете также перетащить мышкой файл из проводника на ярлычек Lppro на рабочем столе.

Чтобы работал способ2, необходимо связать расширения файлов с программой Lppro. Для этого нажмите F5, чтобы открыть окно настроек программы. На вкладке "Разное 1" нажмите кнопку "Связать файлы с Lppro". Появится запрос "Вы уверены?", нажмите кнопку "Yes".
Подробнее см. в разделе Настройки программы. а также здесь>>

Способ 3: Возможно это - наиболее удобный способ. Вы можете открывать списки воспроизведения из окна файлового браузера / подслушки. Дело в том, что файловый браузер Lppro только по умолчанию отображает только звуковые файлы. на самом деле он может работать с любыми файлами и даже запускать другие программы. вам нужно только установить строку фильтрации файлов. Подробно о том как это сделать читайте в разделе окно проигрывателя подслушки / файлового браузера .

Импорт списка старого формата - Lppro V1.xx

Если вы ранше работали с программой Lppro V1.xx, то, возможно, у вас есть готовые списки, которые вы хотели бы использовать в Lppro V2.0. В новой программе используется другой формат файла списка(*.lpl) . Для загрузки файла старого формата (*.lst) предусмотрена функция импорта файла списка. Для вызова этой функции в главном меню прогаммы выберите опцию Файл1 [image] Импортировать Список в формате Lppro 1...


tut_status

Поле Статуса песни.

Поле статуса списка воспроизведения - это специальное поле, которое имеет только два состояния: установленное и сброшенное (очищенное). Если поле установлено, то в нем отображается символ * (звездочка), если поле сброшено, то в нем не отображается ничего. На рисунке ниже представлен фрагмент окна списка воспроизаедения с установленным и сброшенным полем статуса:

Поле статуса используется для нескольких целей.

Поле статуса устанавливается автоматически при старте воспроизведеня песни. Таким образом поле статуса показвает вам, была ли данная песня проиграна в данном сеансе работы (при этом список считается измененным и в строке состояния появляется слово Modified). При следующей загрузке списка (в новом сеансе работы) поле статуса проигранных ранее песен автоматически очищается. Такое поведение поля статуса установлено по умолчанию (после инсталляции программы), но вы можете его изменить в окне настроек.

Некоторые функции, обрабатывающие сразу несколько строк списка, требуют чтобы вы отметили строки, которые хотите обработать. Для этих функций строка считается отмеченной, если у нее установлено поле статуса. Вот список функций, которые работают с отмеченными по полю статуса строками:
Копирование файлов списка в одну папку,
Переписать Тэги mp3 файлов списка,
Удалить со статусом "проиграно",
Скопировать все со статусом "проиграно" в новый список,
Переместить все со статусом "проиграно" в новый список.

Вы можете вручную (независимо от того, проигрывалась песня или нет) установить или сбросить (очистить) поле статуса несколькими способами.

1. Вы можете установить поле статуса сразу во всех сторках текущего списка. Для этого существует опция главного меню Редактирование [image] Установить статус всех песен списка. Кроме того, вы можете установить поле статуса сразу во всех сторках текущего списка нажав на клавиатуре сочетание клавиш Ctrl+J.

2. Вы можете очистить поле статуса сразу во всех сторках текущего списка. Для этого в главногом меню Редактирование [image] Очистить статус всех песен списка. Кроме того, вы можете очистить поле статуса сразу во всех сторках текущего списка нажав на клавиатуре сочетание клавиш Ctrl+K.

3. Вы можете инвертировать (изменить на противоположное) значение поля статуса сразу во всех сторках текущего списка. Для этого в главногом меню Редактирование [image] Поменять статус на противоположный. Кроме того, вы можете инвертировать поле статуса сразу во всех сторках текущего списка нажав на клавиатуре сочетание клавиш Ctrl+L.

4. Вы можете изменить поле статуса любой отдельной строки списка. Для этого щелкните на нужной строке левой кнопкой мышки, одновременно удерживая нажатой клавишу "Alt".


tut_lyriks

Работа с текстами песен (Lyriks)

См. также:
Окно синхронного вывода текста песни (Lyriks)
Окно редактора текста песни

Программа LPPro V2 имеет набор функций для редактирования и синхронного вывода текстов песен (Lyriks). После установки программы функция автоматического вывода на экран текста песни отключена. Для ее активизации включите переключатель "Включить текст" вкладки Разное 2 в окне настроек программы.

Текст песни (Lyriks) может быть создан для любого звукового файла. Файл Lyriks - это обычный текстовый файл с расширением *.txt. При этом имя текстового файла должно совпадать с именем соответствующего звукового файла. Напрмер у нас есть звуковой файл valsboston.mp3, тогда файл со словами для это песни должен иметь имя valsboston.txt. Кроме того, чтобы программа смогла найти файл с текстом песни, он должен распологаться в ТОЙ ЖЕ папке, что и соответствующий ему звуковой файл.

Для синхронного вывода на экран текста песни необходимо открыть окно текста песни (Lyriks). Для этого на панели инструментов нажмите кнопку [image] (или клавишу F9 на клавиатуре компьютера). Подробнее о функциях окна вывода текста см. здесь>>

Если функция синхронного вывода текста песни включена, то в момент загрузки очередного звукового файла из списка воспроизведения, программа ищет соответствующий этому звуковому файлу текстовый файл со словами песни. Если в той папке, в которой расположен звуковой файл нет соответствующего текстового файла, то в окне текста песни (Lyriks) будет выведено примерно следующее сообщение:

Системе не удалось найти файл с текстом песни c:\Audio\Stress\valsboston.txt для звукового файла c:\Audio\Stress\valsboston.mp3

Вы можете создать файл текста песни в редакторе текста песни Текстовый файл должен иметь то же имя, что и звуковой файл, и распологаться в той же папке, Но расширение файла должно быть ть '*.txt"

Если файл найден, то по мере воспроизведения песни начнется вывод текста из тексового файла в соответствии с его разметкой.

Для создания текствого файла песни и его разметки в LPPro предусмотрен специальный текстовый редактор, совмещенный с проигрывателем. Подробно о том как создать файл текста песни для конкретного звукового файла можно прочитать в разделе, плсвященном текстовому редактоу слов песни>>

В общем виде, для работы с текстом песни необходимо проделать следующие шаги:

1. В окне настроек программы включите функцию работы с тексами (переключатель "Включить текст").

2. В списке воспроизведения выделите ту песню, для которой вы хотите создать файл текста песни, щелкнув мышкой на соответствующей строке списка.

3. На панели инструментов щелкните по кнопке [image] или нажмите на клавиатуре F4. Откроется редактор текста песни. Как создать текст песни в редакторе подробно см. здесь>>.

4. После того, как будет создан файл с текстом песни, закройте текстовый редактор. Запустите песню на воспроизведение и откройте окно синхронного вывода текста, щелкнув на кнопке [image] или нажав клавишу F9 на клавиатуре компьютера. По мере воспроизведения файла будет выводиться текст песни в соответствии с разметкой текстового файла.

Вы можете настроить цвет фона, цвет текста и размер шрифта окно синхронного вывода текста по вашему желанию в окне настроек програмы на вкладке "Разное 2".


main_menu

Главное меню программы

В раздел Главное Окно программы>>

Главное Меню обеспечивает доступ ко всем основным функциям Lppro и дополнительным окнам программы. Главное меню состоит из нескольких пунктов или разделов ("Файл1", "Команды" и т.д.). При щелчке мышкой на пункте меню оно раскрывается и появляются подпункты или, опции меню. Многим функциям, вызываемым с помощью Главного Меню, соответствуют клавиши (или сочетания клавиш) на клавиатуре компьютера. На рисунке ниже приведено главное меню программы.

Щелкните мышкой на интересующем вас пункте меню, чтобы получить дополнительную информацию:

Функции работы с файлами Функции работы с файлами Функции управления функции редактирования списков функции поиска функции фоновой музыки опции показа дополнительных окон программы выбор языка интерфейса программы функции работы с окнами списков инструкция и информация о программе

Опция | Описание | клавиатура

Файл 1

Функции работы с файлами

Новый список Создает пустое окно списка воспроизведения и присваивает новому списку имя вида "List" + порядковый номер + расширение файла *.lpl. Например: list5.lpl
Ctrl+N
Добавить файлы Позволяет расширять список воспроизведения, добавляя в него файлы с диска. Вызывает стандартный диалог открытия файла Windows. За раз можно добавить один или несколько файлов из какой-либо одной папки. Для того, чтобы добавить сразу несколько файлов выделите несколько файлов, щелкая на них мышкой и удерживая нажатой клавишу Ctrl. Для выделения ВСЕХ файлов в папке нажмите Ctrl+A.
A
Сканировать папки и добавить файлы Поиск и добавление файлов. Позволяет добавлять файлы в список одновременно из нескольких вложенных папок. Например, вы можете добавить в список все файлы *.wav, которые есть на вашем диске С:. Функция может искать файлы определнного типа или какой-то один определенный файл. Открывается специальное окно. Подробно смотрите в разделе Окно сканирования папок, поиска и добавления файлов.
Ctrl+T
Открыть список Позволяет заргузить с диска файл списка воспроизведения. Если список с таким именем уже открыт, то вам будет предложено загрузить его заново. Если вы ответите "NO", то открытый список с таким именем станет активным. Если вы ответите "YES", то Список будет открыт ЗАНОВО, то есть все изменения, сделанные в нем со времени последнего сохранения, будут потеряны.
Ctrl+O
Присоединить список Слияние двух списков. Позволяет добаввить в открытый список все строки из какого - либо другого списка.
Alt+M
Открыть перфоманс Позволяет загрузить файл "Перфоманса" (фаийл имеет расширение *.lpp). Поробее о работе с перфомансами см. здесь>>
Alt+O
Открыть аудио файл во внешнем редакторе Позволяет открыть звуковой файл, ссылка на который содержится в текущей строке текущего списка . Звуковой редактор должен быть установлен в вашей системе (например SounForge или WaveLab). Назначить нужный звуковой редактор можно в окне настроек программы.
Сохранить список Служит для быстрого сохранения изменений в текущем списке. При этом диалоговое окно не выводится, просто сохраняются изменения в текущем списке. Тем не менее, если список еще небыл созранен на диске, то все равно будет вызвана функция "Сохранить список с новым именем" (см. ниже)
Ctrl+S
Сохранить все списки Сохраняет все открытые в программе списки, то есть выполняет функцию Сохранить список последовательно для всех открытых списков. Если попоадается новый список, то есть тот, который еще ни разу небыл сохранен на диске, то для него будет запршено новое имя (вызывана функция "Сохранить список с новым именем").
Shift+Ctrl+S
Сохранить список с новым именем Позволяет сохранить на диске файл текущего списка воспроизведения, присвоив ему новое имя. Если на диске уже есть файл с таким именем, то он буде переписан (после запроса), иначе на диске будет создан новый файл с введенным именем.
Ctrl+Alt+S
Сохранить Перфоманс Позволяет сохранить текущее состояние программыв виде файла перфоманса (*.lpp). Поробее о работе с перфомансами см. здесь>>
Alt+S
Закрыть все списки Закрывает ВСЕ открытые списки. Если в каком-либо из открытых списков есть несохраненные изменения, то вам будет предложено сохранить эти списки, и только после этого списки будут закрыты.
Закрыть файлы в обоих каналах микшера Когда звуковой файл открыт в Lppro (даже если он не проигрывается в данный момент, а просто загружен ы один из проигрвыателей) , то он "занят" для других приложений. Вы также не сможете переписать тэги mp3 файла, если он открыт в каком-либо устройстве. Данная функция позволяет "освободить", выгрузить звуковые файлы, открытые в виртуальном микшере.
Закрыть аудио файлы во всех устройствах То же, что и предыдущая функция, только закрывает звуковые файлы ао всех устройствах: в виртуальном микшере, проигрывателе подслушки и в фоновом проигрывателе.
Печать списка Открывает окно печати и экспорта списка. Подробнее см. в разделе Окно печати и экспорта списка>>
Ctrl+P
Импортировать список в формате Lppro 1 Если вы работали с программой Lppro 1.XX, то скорее всего, у вас есть списки, которые вы хотели бы использовать при переходе к программе Lppro V2.0. Lppro V2.0 использует другой формат файлов списков, нежели Lppro 1.XX. Данная функция служит для загрузки списков старой программы (файлы с расширением *.lst). После того как список загружен, он может быть сохранен в формате LpproV2.0.
Экспортировать список Открывает окно печати и экспорта списка. Подробнее см. в разделе Окно печати и экспорта списка>>
Автоматически очищать статус при загрузке Если включена эта функция (установлена галочка), то при загрузке списка воспроизведения будет очищаться поле статуса списка, то есть будет считаться, что все песни списка еще небыли проиграны в данном сеансе работы. Если эта функция отключена (нету галочки), то при загрузке списка поле статуса песен будет в том состоянии, как при последнем сохранения списка.
Выход из программы Заканчивает работу с Lppro. Если в момент выхода из программы имеются открытые списки с несохраненными изменениями, то программа предложит вам сохранить эти списки. При выходе из программы сохраняются все настройки, открытые окна, открытые списки и позиции курсора в списках. Иными словами полностью сохраняется состояние программы на момент выхода. При последующем запуске программы восстанавливается ее состояние, которое имело место в момент выхода. Примечание: для того, чтобы списки воспроизведения, открытые в момент выхода из программы были открыты при следующем ее запуске, необходимо, чтобы эти списки были сохранены на диске.
Alt+F4

Файл 2

Функции работы с файлами

Информация о файле Открывает окно с подробной информацией о звуковом файле, ссылка на который сохранена в данной строке списка. Если это файл mp3, то в этом окне вы можете также отредактировать информацию, которая хранится в тэгах mp3 файла. Подробнее см. в разделе Окно информации о файле / редактирования тэгов mp3-файла.
i
Проверить корректность ссылок В процессе работы может возникнуть такая ситуация, когда строки списка будут ссылаться на не существующие на самом деле файлы. Вы можете добавить файлы в список воспроизведения Lppro, а на следующий день удалить какие-то из этих файлов не из Lppro, а из проводника Windows или файлового менеджера. После этого вы запускаете Lppro и загружаете список. В результате некоторые строки списка будут ссылаться на несуществующие файлы, что вызовет ошибку при воспроизведении из списка. Данная функция служит для проверки корректности всех строк списка. Функция проверяет, существует ли на диске файл с именем, сохраненным в строке списка. Если файл не существует, то в поле Названия песни будет прописано ##NO FILE!## ("отсутствует файл"), а в поле Исполнителя - ##INVALID RECORD## ("Ошибочная запись"). Потом вы можете сами удалить эти строки, либо порытаться вручную найти отсутствующие файлы. (Есть также функция, которая автоматически удаляет ошибочные строки из списка. См. раздел меню Редактирование>>)
Ctrl+Q
Сканировать папки и добавить файлы... Эта очень полезная функция позволяет добавить в список сразу множество файлов из нескольких вложенных папок или сразу все файлы с какого-либо диска. Подробно смотрите в разделе Окно сканирования папок, поиска и добавления файлов>>.
Ctrl+T
Скопировать / переместить файлы в папку... Функция позволяет скопировать или переместить звуковые файлы, на которые ссылаются строки текущего списка в какую - либо одну папку. Подробно смотрите в разделе Окно копирования файлов списка>>.
Shift+F5
Переписать Тэги mp3 файлов списка

Переписывает тэги файлов списка в соответствии с информацией списка. При этом информация из поля "Название" записывается в тэг "Titlle", информация из поля "Исполнитель" помещается в тег "Artist". Значение поля "Темп" записывается в тэг "Track". Остальные тэги файла не изменяются. Будут обработаны только строки с установленным полем статуса (помеченным символом * (звездочка)).
Для того, чтобы установить поле статуса у ВСЕХ строк списка, нажмите Ctrl+J. Для того, чтобы очистить поле статуса у ВСЕХ строк списка, нажмите Ctrl+K. Для того, чтобы инвертировать (поменять на противоположный) поле статуса у ВСЕХ строк списка, нажмите Ctrl+L. Для того, чтобы изменить статус ОДНОЙ строки, щелкните на ней мышкой, одновременно удерживая на клавиатуре клавишу Alt.

Внимание! Эта функция работает только с mp3 - файлами!

Удалить строку списка и отправить файл в корзину Эта функция удаляет строку из списка и одновременно удаляет соотвктствующий звуковой файл с жеского диска, отправляя его в корзину. Для удаления ненужных звуковых файлов с диска рекомендуется пользоваться этой функцией, чтобы уменьшить вероятность появления ошибочных ссылок в списках воспроизведения. Одновременно может быть удалена только одна строка с соответствующим ей файлом.
Ctrl+Delete
Удаление файлов с диска (Будьте осторожны!) Эта функция удаляет строки из списка и соответствующие им файлы. В отличие от предыдущей функции она не отправляет звуковые файлы в корзину, а безвозвратно удаляет их. Пользуйтесь этой функцией осторожно и только когда абсолютно уверены, что хотите удалить файлы. Одновременно может быть удалено несколько записей и файлов (сколько выделено в списке). перед тем, как удалить файлы, программа ДВАЖДЫ спросит вас, уверены ли вы в том, что делаете.
Ctrl+Alt+F8
Поменять букву диска во всем списке Изменяет букву диска в путях поиска файла всех строк списка.

Команды

Функции управления проигрыванием из списка
Проиграть текущую песню Запускает на воспроизведение текущую (выделенную курсором) песню списка.
Shift+Enter
Проиграть следующую Запускает на воспроизведение следующую песню списка.
Стоп останавливает воспроизведение по списку

Shift+Space
Проиграть в подслушке Запускает воспроизведение текущей (выделенной курсором) песни в проигрывателе подстушки через устройство подслушки. Если окно проигрывателя подслушки невидимо, то оно открывается.
Shift+F7
Установить выделенную песню следующей Предназначена для изменения порядка следования песен списка. делает выделенную песню Следующей. После окончания воспроизведения то песни, которая проигрывается в данный момент, начнет воспроизводиться та песня, которую вы установили как Следующую, и дальше процесс воспроиведения по списку будет продолжаться от этой песни.
Перейти к строке с номером... Открывает маленькое окно, в котором вы можете ввести номер строки для быстрого перехода к ней. имеет смысл, если в списке очень много строк.
Ctrl+G

Редактирование

Функции изменения и редактирования списка воспроизведения

Редактировать строку списка Открывает доступ к функциям редактирования строки списка. Подробнее см. в разделе Окно редактирования строки (записи) списка>>
E
Копировать в карман Копирует в Карман текщую строку (или несколько выделенных строк).
Ctrl+C
Вырезать и поместить в карман Вырезает (копирует и удаляет из списка) в Карман текщую строку (или несколько выделенных строк).
Ctrl+X
Вставить из кармана Вставляет в список строки из Кармана.
Ctrl+V
Удалить строки Удаляет выделенные строки из списка
Delete
Сортировка Сортировка списка по полям. Открывается вложенное меню, где вы можете выбрать поле, по которому хотели бы отсортировать ваш список. Есть также возможность перемешать все строки в случайном порядке.
Очистить весь список Удаляет из списка ВСЕ строки.
Удалить со статусом "проиграно"

Удаляет только те строки, у которых установлено поле статуса.

Для того, чтобы установить поле статуса у ВСЕХ строк списка, нажмите Ctrl+J. Для того, чтобы очистить поле статуса у ВСЕХ строк списка, нажмите Ctrl+K. Для того, чтобы инвертировать (поменять на противоположный) поле статуса у ВСЕХ строк списка, нажмите Ctrl+L. Для того, чтобы изменить статус ОДНОЙ строки, щелкните на ней мышкой, одновременно удерживая на клавиатуре клавишу Alt.
Shift+Ctrl+Delete
Скопировать все со статусом "проиграно" в новый список

Создает новое окно списка и копирует в этот новый список те строки из текущего списка, у которых установлено поле статуса.

Для того, чтобы установить поле статуса у ВСЕХ строк списка, нажмите Ctrl+J. Для того, чтобы очистить поле статуса у ВСЕХ строк списка, нажмите Ctrl+K. Для того, чтобы инвертировать (поменять на противоположный) поле статуса у ВСЕХ строк списка, нажмите Ctrl+L. Для того, чтобы изменить статус ОДНОЙ строки, щелкните на ней мышкой, одновременно удерживая на клавиатуре клавишу Alt.
Ctrl+Alt+C
Переместить все со статусом "проиграно" в новый список

Создает новое окно списка и перемещает (удаляет в текущем списке и помещает в новый) в этот новый список те строки из текущего списка, у которых установлено поле статуса.

Для того, чтобы установить поле статуса у ВСЕХ строк списка, нажмите Ctrl+J. Для того, чтобы очистить поле статуса у ВСЕХ строк списка, нажмите Ctrl+K. Для того, чтобы инвертировать (поменять на противоположный) поле статуса у ВСЕХ строк списка, нажмите Ctrl+L. Для того, чтобы изменить статус ОДНОЙ строки, щелкните на ней мышкой, одновременно удерживая на клавиатуре клавишу Alt.
Ctrl+Alt+X
Очистить статус всех песен списка Позволяет очистить поле статуса у ВСЕХ строк текущего списка
Ctrl+K
Установить статус всех песен списка Позволяет установить поле статуса у ВСЕХ строк текущего списка
Ctrl+J
Поменять статус на противоположный Позволяет изменить значение поля статуса у ВСЕХ строк текущего списка на противоположное (инвертировать).
Ctrl+L
Удалить некорректные строки (отсутствуют файлы)

В процессе работы может возникнуть такая ситуация, когда строки списка будут ссылаться на не существующие на самом деле файлы. Вы можете добавить файлы в список воспроизведения Lppro, а на следующий день удалить какие-то из этих файлов не из Lppro, а из проводника Windows или файлового менеджера. После этого вы запускаете Lppro и загружаете список. В результате некоторые строки списка будут ссылаться на несуществующие файлы, что вызовет ошибку при воспроизведении из списка. Данная функция служит для удаления таких ошибочных строк списка. Функция проверяет, существует ли на диске файл с именем, сохраненным в строке списка. Если файл не существует, то в строка удаляется.

Удаляются только строки списка, сами файлы не удаляются.

Удалить строки с ошибочным форматом файла

Удаляет из списка строки со ссылками на файлы, которые не могут быть проиграны в Lppro (по причине отсутствия драйвера декодера или по дру3гим причинам).

Удаляются только строки списка, сами файлы не удаляются.

Изменить цвета и шрифты Открывает окно, в котором вы можете настроить вид текущего списка (цвета, линии, шрифты).
Режим работы кармана

Открывает подменю с опциями изменения режимов работы кармана:

Очищать карман при копировании и вырезании - Если этот режим включен, то при копировании в карман новой информации старая информация стирается (режим работы, аналогичный тому, как работает буфер обмена Windows). Если этот режим отключен, то строки, копируемые в карман будут добавляться к уже имеющимся в кармане.

Очищать карман при вставке в список - Если этот режим включен, то при всавке информации из кармана в список информация в кармане стирается (строки "перемещаются" в список). Если этот режим выключен, то строки просто копируются из кармана в список (режим работы, аналогичный тому, как работает буфер обмена Windows).

Вставлять в список в позицию ниже выделенной - Если этот режим активен, то информация из кармана вставляется в список в позицию строки, ниже текущей. Иначе информация вставляется начиная с позиции текущей строки.

См. также раздел Окно Кармана>>.

Поиск

Функции поиска информации в списках

Найти

Поиск по списку. Открывает окно поиска, кде вы можете выбрать поля, по содержимому которых будет производиться поиск и ввести строку для поиска. Поиск ведется в текущем списке. Подробнее см. Окно задания параметров поиска в списках>>.
Ctrl+F
Найти следующую Поиск следующей строки, удовлетворяющей параметрам поиска, заданным в Окне задания параметров поиска. Поиск ведется в текущем списке.
F3
Найти все совпадения и создать новый список Функция ищет все строки, удовлетворяющие параметрам поиска, заданным в Окне задания параметров поиска. Затем создается новый список и в него помещаются все найденный строки. Вы можете выбрать, искать в текущем списке или во ВСЕХ открытых списках.
Ctrl+Alt+F

Фоновая музыка

Функции управления фоновым проигрывателем из главного окна программы

Показать фоновый проигрыватель Открывает окно проигрывателя фоновой музыки
Загрузить список в фоновый проигрыватель Позволяет загрузить файл списка в ,проигрывателя фоновой музыки не открывая его окна
Автоматический режим громкости ФП Включение автоматического режима работы фонового проигрвателя. Дублирует соответствующий выключатель в окне проигрывателя фоновой музыки.
Случайное воспроизведение Режим случайного выбора песни из списка фоновой музыки. Дублирует соответствующий выключатель в окне проигрывателя фоновой музыки.
Старт воспроизведения фоновой музыки
Пауза воспроизведения фоновой музыки
Стоп воспроизведения фоновой музыки
Вручную инициировать процесс ввода громкости фоновой музыки
Вручную инициировать процесс уменьшения громкости фоновой музыки
Текущая песня | Выводится название (если в списке не прописано название, то имя файла) текущей песни в проигрывателе фоновой музыки.

Показать...

Открывает дополнительные окна программы.

Микшер Открывает окно виртуального микшера.
Карман Открывает окно кармана.
Фоновый Проигрыватель Открывает окно проигрывателья фоновой музыки.
Окно текста песни Открывает окно синхронного вывода текста песни (Lyriks).
Редактор текста песни Открывает окно текстового редактора слов песни Lyriks.
Редактор огибающей кроссфейда Открывает окно редактирования огибающей кроссфейда
Настройки Открывает окно настроек программы.
Подслушку и файловый браузер Открывает окно подслушки и файлового браузера
Перейти к звучащему списку позволяет активизировать Звучащий список.
F3

Language

English | Позволяет выбрать Английский язык интерфейса программы
Russian | Позволяет выбрать Русский язык интерфейса программы

Окно
Tile Vertically, Tile Horizontally, Cascade | Эти опции позволяют упорядочить расположение окон списков на экране
Minimize All | Сворачивает (минимизирует) все окна списков (но не закрвает их)
Следующий список Делает текущим следующий из открытых списков.
H
Предыдущий список Делает текущим предыдущий из открытых списков.
G

Справка
Cправка по Lppro Открывает эту справочную систему
F1
Регистрация | Завускает программу регистрации. Этот пункт меню показвается только в незарегистрированной версии программы. После регистрации больше не выводится.
О программе | Показвает окно с информацией о текущей версии и пользователе программы


main_window

Главное окно программы

Главное окно программы - это то окно, которое вы видите при первом запуске программы. с помощью меню главного окна вы имеете доступ ко всем основным функциям Lppro и ко всем дополнительным окнам программы. Под главным меню окна распологается панель инструментов с кнопками быстрого доступа к часто используемым функциям. Главное окно программы является родительским для всех списков воспроизведения, окна которых являются дочерними по отношению к главному окну. При закрытии главного окна программы вы закрываете саму программу.

Ниже на рисунке представлено главное окно программы. Щелкните мышкой на интересующем вас объекте и вы получите дополнительную информацию о нем.

Главное меню программы Панель инструментов Регулятор общей громкости основного устройства Строка состояния Окно активного списка окно неактивного списка


main_toolbox

панель инструментов главного окна

На панели инструментов расположены кнопки быстрого вызова часто используемых функций программы.

Щелкните на интересующем вас объекте чтобы получить информацию о нем:

Закрывает ВСЕ открытые списки. Если в каком-либо из открытых списков есть несохраненные изменения, то вам будет предложено сохранить эти списки, и только после этого списки будут закрыты.

Создает пустое окно списка воспроизведения и присваивает новому списку имя вида "List" + порядковый номер + расширение файла *.lpl. Например: list5.lpl

Позволяет заргузить с диска файл списка воспроизведения. Если список с таким именем уже открыт, то вам будет предложено загрузить его заново. Если вы ответите "NO", то открытый список с таким именем станет активным. Если вы ответите "YES", то Список будет открыт ЗАНОВО, то есть все изменения, сделанные в нем со времени последнего сохранения, будут потеряны.

Служит для быстрого сохранения изменений в текущем списке. При этом диалоговое окно не выводится, просто сохраняются изменения в текущем списке. Тем не менее, если список еще небыл созранен на диске, то все равно будет вызвана функция "Сохранить список с новым именем" (см. ниже)

Позволяет сохранить на диске файл текущего списка воспроизведения, присвоив ему новое имя. Если на диске уже есть файл с таким именем, то он буде переписан (после запроса), иначе на диске будет создан новый файл с введенным именем.

Сохраняет все открытые в программе списки, то есть выполняет функцию Сохранить список последовательно для всех открытых списков. Если попоадается новый список, то есть тот, который еще ни разу небыл сохранен на диске, то для него будет запршено новое имя (вызывана функция "Сохранить список с новым именем").

Открывает окно печати и экспорта списка. Подробнее см. в разделе Окно печати и экспорта списка>>

Позволяет загрузить файл "Перфоманса" (фаийл имеет расширение *.lpp). Поробее о работе с перфомансами см. здесь>>

Позволяет сохранить текущее состояние программыв виде файла перфоманса (*.lpp). Поробее о работе с перфомансами см. здесь>>

Позволяет расширять список воспроизведения, добавляя в него файлы с диска. Вызывает стандартный диалог открытия файла Windows. За раз можно добавить один или несколько файлов из какой-либо одной папки. Для того, чтобы добавить сразу несколько файлов выделите несколько файлов, щелкая на них мышкой и удерживая нажатой клавишу Ctrl. Для выделения ВСЕХ файлов в папке нажмите Ctrl+A.

Поиск и добавление файлов. Позволяет добавлять файлы в список одновременно из нескольких вложенных папок. Например, вы можете добавить в список все файлы *.wav, которые есть на вашем диске С:. Функция может искать файлы определнного типа или какой-то один определенный файл. Открывается специальное окно. Подробно смотрите в разделе Окно сканирования папок, поиска и добавления файлов.

Открывает окно с подробной информацией о звуковом файле, ссылка на который сохранена в данной строке списка. Если это файл mp3, то в этом окне вы можете также отредактировать информацию, которая хранится в тэгах mp3 файла. Подробнее см. в разделе Окно информации о файле / редактирования тэгов mp3-файла.

Сортировка списка по полям. Открывается выпадающее меню, где вы можете выбрать поле, по которому хотели бы отсортировать ваш список. Есть также возможность перемешать все строки в случайном порядке:

Удаляет выделенные строки из списка

Эта функция удаляет строку из списка и одновременно удаляет соотвктствующий звуковой файл с жеского диска, отправляя его в корзину. Для удаления ненужных звуковых файлов с диска рекомендуется пользоваться этой функцией, чтобы уменьшить вероятность появления ошибочных ссылок в списках воспроизведения. Одновременно может быть удалена только одна строка с соответствующим ей файлом.

Открывает доступ к функциям редактирования строки списка. Подробнее см. в разделе Окно редактирования строки (записи) списка>>

Открывает окно кармана.

Открывает окно виртуального микшера.

Открывает окно проигрывателья фоновой музыки.

Открывает окно синхронного вывода текста песни (Lyriks).

Открывает окно текстового редактора слов песни Lyriks.

Открывает окно подслушки и файлового браузера

Проигрывает выделенную песню списка в проигрывателе подслушки.

Переключает интерфейс программы в компактный режим - скрывает главное окно со всеми списками, оставляя на экране проигрыватель подслушки. Режим удобен для фонового проигрывания музыки и при воспроизведении файлов из проводника Windows.

Открывает окно настроек программы.

- полоса бытрого поиска по файлу. Графически отображает текущую позицию воспроизведения файла. Для перехода к нужному месту песни щелкните на соотв. участке полоски.

- Индикаторы уровня воспроизведения

- дисплей времени. Во время воспроизведения он отображает, прошедшее с начала воспроизведения, либо оставшееся до конца воспроизведения время. переключаться между этими режимами можно щелкая мышкой на индикаторе времени одного из каналов.

Запускает на воспроизведение текущую (выделенную курсором) песню списка.

Пауза - временная остановка воспроизведение по списку.

останавливает воспроизведение по списку.

Запускает на воспроизведение следующую песню списка.

- кнопочка и окошко следующей песни. Здесь выводится название Следующей песни. При воспроизведении музыки по списку очередная песня загружается в микшер и начинает воспроизводиться. Та песня строка которой расположена ниже текущей, автоматически становится СЛЕДУЮЩЕЙ (Next) в порядке воспроизведения. При окончании воспроизведения текущей песни начинает проигрываться следующая, она становится текущей, и так далее. Сделать любую песню списка следующей можно, нажав на кнопочку Next слева от окошка , или перетащив мышкой (при нажатой клавише Ctrl) песню из списка на это окошко.

- цифры показвают громкость основного устройства (общую громкость)


win_edit

Окно редактирования строки (записи) списка

Окно редактирования записи списка - это основной инструмент для изменения информации в строке списка. Вы можете изменить информацию о названии песни, исполнителе, установить или сбросить статус строки списка, определить темп песни. В этом окне вы также можете настроить и задать громкость для данной конкретной песни и индивидуальное время кроссфейда.
Окно редактирования имеет собственный проигрыватель, который поможет вам прослушать песню, информацию о которой вы редактируете (это особенно необходимо при установке индивидуальной громкости песни). Прослушать песню можно независимо от воспроизведния списка, так как проигрватель окна редактирования воспроизводит через устройство подслушки. (см. об аудиоустройствах >>)

Для того, чтобы получить информацию о каком-либо элементе управления окна, щелкните на нем мышкой:

Путь к звуковому файлу и имя файла. Двойной щелчок мышки на этой области приведет к открытию папки, в которой расположен звуковой файл, в проводнике Windjws или в файловом менеджере, выбранном в окне настроек программы. Щелчок правой кнопки мыши откроет выпадающее меню:

Выбор опции Browse соответствует двойному щелчку на области миени и пути файла и открывает папку, в которой расположен звуковой файл, в проводнике Windjws или в файловом менеджере, выбранном в окне настроек программы.

Выбор опции Copy Path and FileName поместит в буер обмена Windjws строку с именем файла вместе с полным путем к нему.

Строка редактирования Название - здесь вы можете изменить содержимое поля Названия.

Строка редактирования Исполнитель - здесь вы можете изменить содержимое поля Исполнителя.

Выключатель Статус - связяан с полем статуса песни. Выставляя или убирая флажок этого переключателя вы можете установить или очистить поле статуса списка.

- Щелкните мышкой на этой области для того, чтобы установить или определить темп песни. При этом откроется окно определителя темпа песни. Подробнее см.>>

Предустановка времени кроссфейда -Предустановка времени кроссфейда для данной конкретной песни. Позволяет запомнить время кроссфейда в списке воспроизведения индивидуально для одной песни. Время кроссфейда будет установлено в моент загрузки песни из списка воспроизведения, если в установках включен режим Время КФ из списка. Время устанавливается в секундах.

Предустановка громкости песни -Предустановка громкости для данной конкретной песни. Позволяет запомнить громкость в списке воспроизведения индивидуально для одной песни. Громкость будет установлена в моент загрузки песни из списка воспроизведения, если в установках включен режим Громкостьиз списка. Время устанавливается в секундах.

Полоса прокрутки времени песни - позволяет бымтро перейти к желаемомоу участку песни и графически отображает время воспроизведения.

Кнопки Плэй, Пауза и Стоп - управление процессом воспроизведения.

Кнопка OK - выход из окна редактирования с сохранением изменений в редактируемой строке списка.

Кнопка Cancel - выход из окна редактирования с отменой изменений, сделанных в редакторе строки. Строка остается без изменений.

Кнопка Перезагр. - загружает в окно редактирования исходную информацию из списка воспроизведения, то есть приводит редактор к тому состоянию, в котором он был в момент открытия окна.

Регулятор громкости воспроизведения. - проигрыватель окна редактирования строки воспроизводит через устройство подслушки, поэтому данный регулятор изменяет громкость устройства подслушки.


win_search

Окно задания параметров поиска в списках

Поиск - одна из наиболее часто используемых операций при работе со списками. В LPPro имеется ряд функций для поиска в списках воспроизведения.

Окно задания параметров поиска:

Для начала поиска необходимо:

1. Задать как минимум одно поле, по которому будет производиться поиск. Искать можно по имени файла, названия или исполнителя. Для включения нужного поля в процесс поиска, установите флажок у названия соответствующего поля.

2. Задать строку для поиска.

3. Нажать кнопку "Искать". Строка списка, в которой будет найдено первое совпадение, будет выделена курсором. Для дальнейшего поиска совпадений нажать "Снова" или клавишу F3 на клавиатуре.

В режиме поиска всех совпадений с созданием нового списка появляется выключатель "искать во всех открытых списках". В этом случае при нажатии кнопки "Искать" будет производиться поиск во всех открытых списках воспроизведения. Если будет найдено хотя бы одно совпадение, то будет создан новый список и в него будут добавлены строки, удовлетворяющие параметрам поиска.


win_bpm

Окно определителя темпа песни

Окно определителя темпа песни служит для определения темпа и установки поля темпа в списке воспроизведения. В последствии вы можете отсортировать список по полю темпа.

Окно определителя темпа может быть вызвано только из окна редактирования строки списка.

 дисплей темпаполоса поиска по файлукнопка Плэйручная установка темпавыход с сохранением значения темпаобласть для определения темпа с помощью мышкиРегулятор громкостиКнопка ПаузаКнопка Стоп

Для того, чтобы установить темп песни:

1. Если песня еще не проигрывается, запустите ее на воспроизведение, нажав кнопку [image]. Песня начнет воспроизводиться через устройство подслушки. С помощью полоски поиска [image] выберите в песне такой участок, где наибоее ярко выражена ритмическая структура. Регулятором громкости у правой границы окна насторйте желаемую громкость воспроизведения.

2. Нажимайте на клавиатуре клавишу пробел в такт с темпом песни (или щелкайте мышкой на прямоугольной области синего цвета справа). Программа будет вычислять темп нажатий в ударах в минуту (BPM).

Внимание! для корректного определения темпа необходимо сделать не менее 5 нажатий.

3. В числовом редакторе [image] вы можете вручную откорректировать значение темпа.

4. Нажмите кнопку OK. Окно определителя темпа закроется, а в окне редактирования строки списка будет прописано значение темпа песни. В список значение темпа будет внесено только после нажатия кнопки OK в окне редактирования строки.


win_options

Окно настроек программы

Окно настроек программы содержит 4 страницы, на которых расположены органы управления, позволяющие вам настроить параметры программы. Все настройки сохраняются при выходе из программы и автоматически восстанавливаются при последующем ее запуске. Все настройки также сохраняются в файлах перфомансов и восстанавливаются при загрузке перфомансов. Таким образом вы можете сделать себе настройки "на все случаи".

Название органов управления, используемых далее в тексте:

- Выключатель или флажок.

- Радиокнопка. Используются группами от двух. Включеной может быть только одна из группы. Получила назание "радиокнопка" из-за сходства с переключателями диапазонов радиоприемника.

- числовой редактор. Служит для установки какого - либо числового значения.

- строковый редактор. Служит для ввода строки текста.

- выпадающий список. Позволяет выбрать одну из нескольких строк при нажатии на кнопочку в правом углу.

Окно настроек параметров программы содержит следующие вкладки или страницы:

Страница "Воспроизведение" - относится к основному устройству - устройству виртуального микшера. Позволяет настроить процесс воспроизведения по списку.

Страница параметров воспроизведения. Щелкните на интересующем вас объекте чтобы получить информацию о нем:

Выключатель Авто Стоп. Если режим автостоп включен (установлен флажок), то после окончания проигрывания каждой песни списка воспроизведение будет останавливаться. Вы должны сами запустить воспроизведение следующей песни. режим удобен для музыкантов, играющих или поющих под минусовки. Если это время запущен фоновый проигрыватель и в нем задан режим "авто", то после срабатывания автостопа будет плавно введена громкость фоновой музыки. (см. раздел Проигрватель фоновой музыки).
Если же режим автостопа отключен, то песни из списка будут автоматически загружаться и проигрываться одна за другой.

Выключатель Громкость из списка . В списке воспроизведения имеется возможность созранять настройку громуости для каждой песни. Если данный режим включен (установлен флажок), то при запуске очередной песни из списка будет также автоматически установлена громкость, которую вы установили для этой песни (как установить громкость для каждой конкретной песни читайте в разделе Окно редактирования строки (записи) списка ). Если же этот режим отключен, то громкость канала может быть установлена вручную в окне виртуального микшера.

Выключатель Время КФ из списка . В списке воспроизведения имеется возможность созранять предустановку времени кроссфейда для каждой песни. Если данный режим включен (установлен флажок), то при запуске очередной песни из списка будет также автоматически установлено время кроссфейда (как установить время кроссфейда для каждой конкретной песни читайте в разделе Окно редактирования строки (записи) списка ). Если же этот режим отключен, то время кроссфейда будет соответствовоать установленному на этой странице регулятором времени кроссфейда.

Старт по фейдеру - имитация соответствующего режима некоторых "железных" DJ пультов. Данный режим возможен только при ручном кроссфейде, поэтому при включении Старта по фейдеру Lppro автоматически включит режим ручного кроссфейда. При включении режима Старта по фейдеру в окне виртуального микшера активизируются маркеры старта и стопа каналов и разрешается использование ручки кроссфейдера. Старт по фейдеру осущетвляется следующим образом: предположим, что в данный момент времени у нас воспроизводится песня, загруженная в левый канал витруального микшера (не путать с левым стереоканалом!) и ручка кроссфейдера находится в крайнем левом положении, как показано на рисунке:

правый канал стартует здесь Правый канал останавливается здесь Левый канал останавливается здесь Левый канал стартует здесь Движок ручного кроссфейдера
начинаем медленно передвигать ручку кроссфейдера слева направо. Громкость воспроизводимой песни начинает постепенно уменьшаться.
Первый слева зеленый маркер в виде треугольника - это позиция ручки кроссфейдера, в которой стартует воспроизведение в правом канале (не в правом стереоканале, а в правом, или втором, канале виртуального микшера). Когда ручка окажется в области этого маркера, начнет воспроизводиться песня, загруженная в противоположный, правый канал виртуального микшера. Продолжаем передвигать ручку вправо. При этом первый слева красный квадратик - маркер игнорируется. Сейчас у нас воспроизводятся обе песни одновременно, причем по мере продвижения дрижка вправо громкость песни в первом канале микшера постепенно уменьшается, а во втором (который справа) - увеличивается. Второй красный квадратик в правой части окна - это маркер остановки первого (того который слева) канала. Когда ручка кроссфейдера оказывается в области этого маркера, воспроизведение в первом канале останавливается, а во втором продолжает наращиваться громкость. Таким образом мы переводим ручку кроссфейдера в крайнее правое положение. Теперь воспроизводит только второй канал. Если мы теперь начнем плавно передвигать ручку справа налево, то весь процесс повторится в обратном порядке. При достижении ручки маркеров остановки канал может перходить либо в режим СТОП, либо в режим ПАУЗА. Это зависит от состояния радиокнопок на панельке "Переключение каналов" (см. далее по тексту)

Группа радиокнопок Режим Фейда.

Радиокнопка КФ отключен. при смене песен кроссфейд не выполняется. Следующая песня стартует только после окончания предыдущей. Не выполняется также фейд при старте и остановке воспроизведения, даже если включены переключатели этих режимов.

Радиокнопка Авто КФ. Это режим работы по умолчанию.
Алгоритм автоматического кроссфейда работает следующим образом: Когда до окончания воспроизведения песни остается время, равное (или менньше) установленного времени кроссфейда, то в противоположный канал микшера загружается очередная песня из списка и начинается ее воспроизведение. На протяжении времени кроссфейда каналы воспроизводят одновременно. Грмкость первой песни плавно уменьшается до нуля, а громкость второй плавно увеличивается. Таким образом, одна песня плавно переходит в другую. Закон, по которому изменяется громкость при кроссфейде ("кривая огибающей кроссфейда") может быть изменен в редакторе огибающей кроссфейда. Если вы установите время кроссфейда больше половины продолжительности звучания песни, то при выполнении кроссфейда время его будет автоматически уменьшено (но только для данной песни).

Радиокнопка Ручной КФ.
При включении этого режима разблокируется движок ручного кроссфейда ("Кроссфейдер") на панели виртуального микшера. При этом вы можете загружать файлы в каналы микшера и независимо проигрывать их, тог есть одновременно могут работать оба канала микшера. При этом баланс громкости между ними регулируется движком кроссфейдера. В режиме ручного кроссфейда возможен режим Старта По Фйдеру.

Переключатель Фейд при старте. Есои этот режим включен, то

Если этот режим включен, то при запуске воспроизведения из списка будет произведен Fade In, то есть плавное увеличение громкости от нуля до установленного значения. Время фейда равно времени кроссфейда, установленному цифровым редактором времени кроссфейда.

Переключатель Фейд при останове .

Если этот режим включен, то при останове воспроизведения из списка будет произведен Fade Out , то есть плавное уменьшение громкости до нуля (это аналог концевого фейда, но работает за счет механизма кроссфейда). Время фейда равно времени кроссфейда, установленному цифровым редактором времени кроссфейда.

Числовой редактор Время кроссфейда - позволяет установить время кроссфейда (в секундах). также влияет на время фейда при старте и фейда при останове.

Группа радиокнопок Переключение каналов.

Определяет то, каким образом будет останавливаться воспроизведение при активном режиме Старта по Фейдеру. Если выбрана радиокнопка Пауза, то противоположный канал будет сотанавливаться в режиме паузы. Если выбрана радиокнопка Стоп, то противоположный канал будет сотанавливаться в режиме стоп.

Числовой редактор Время концевого фейда - позволяет установить время концевого затухания (в секундах)

Еще один вид феда в Lppro - Это концевое затухание (End Fade). Концевое затухание затухание работает независимо от механизма кроссфейда. Концевое затухание осуществляет плавное уменьшение громкости воспроизведения песни и затем останавливает воспроизведение. Концевое затухание инициализируется только из окна виртуального микшера нажатием клавиши

Кнопка OK. - подтверждение изменений настроек. При нажатии этой кнопки ваши настройки всупают в силу, а окно настроек закрывается.

Кнопка Cancel. - Выход из окна настроек и отмена всех изменений.

Страница "Система"

страница параметров системы. Щелкните на интересующем вас объекте чтобы получить информацию о нем:

закладка страницы параметров ыоспроизведения различные настройки 1 различные настройки 2 назначение основного звукового устройства назначение звукового устройства фоновой музыки назначение звукового устройства подслушки. Путь к исполняемому файлу аудиоредактора

Программа Live Performance Pro поддерживает работу с тремя отдельными звуковыми устройствами. Это могут быть отдельные физические звуковые карты, одна звуковая карта с несколькими отдельными стереовыходами (многоканальный аудиоинтерфейс), либо их сочетания. Главное - чтобы Windows "видел" их как отдельные аудиоустройства.

Lppro имеет три раздельных звуковых канала:

1. Канал виртуального микшера, или Основной канал. Через устройство, назначенное на этот канал производится проигрывание из списков воспроизведения. Канал Виртуального микшера имеет два виртуальных канала для реализации адгоритма кроссфейда. На этот канал желательно назначить наиболее высококачественную звуковую карту.

2. Канал фоновой музвки. Через этот канал работает проигрыватель фоновой музыки. Часто для фоновой музыки используется то же устройство, что и для основного канала, но иногда возникает потребность назначить его на отдельное устройство.

2. Канал Подслушки. Через этот канал работает проигрыватель подслушки. Канал подслушки наиболее часто назначается на отдельную звуковую карту. Обычно используется устройство, к которому можно подключть наушники. Кроме того, через устройство подслушки воспроизводят и вспомогательнве проигрыватели различных окон Lppro - окна редактирования строки, окна редактирования темпа, окна сканирования и добавления файлов, окна редактора текста песни.

По умолчанию (в момент первого запуска) все три канала назначены на одно и то же устройство - то, которое используется в Windows по умолчанию.

Если вы используете звуковую карту семейства SB Live! или Audigi фирмы Creative, то мы рекомендуем установить драйвера от KX. В этом случае вы сможете использовать фронтальные и тыловые выхода карты как различные аудиоустройства. Традиционно тыловые выхода этих хвуковых карт - более качественные. Было бы логично использовать их как устройство для основного канала. В то же время на фронтальных выходах установлены усилители наушников и они более мощные, поэтому фронтальные выхода лучше использовать в качестве устройства для канала подслушки и подключить туда наушники.

Выпадающий список Устройство Виртуального Микшера - позволяет назначить звуковое устройство для основного канала. Вы не можете поменять устройство, если в данный момент происходит воспроизведение через этот канал. Сначала остановите воспроизведение, а потом выбирайте устройство!

Выпадающий список Устройство Фонового проигрывателя - позволяет назначить звуковое устройство для канала фоновой музыки. Вы не можете поменять устройство, если в данный момент происходит воспроизведение через этот канал. Сначала остановите воспроизведение, а потом выбирайте устройство!

Выпадающий список Устройство подслушки - позволяет назначить звуковое устройство для канала подслушки. Вы не можете поменять устройство, если в данный момент происходит воспроизведение через этот канал. Сначала остановите воспроизведение, а потом выбирайте устройство!

Внешний Аудиоредактор - сторковый редактор и кнопка. В строке редактора вы можете ввести путь к исполняемому файлу внешнего аудиоредактора, в который будет загружен файл из текущей строки списка при вызове функции главного меню Файл1 > Открыть аудио файл во внешнем редакторе.
Справа от строкового редактора расположена кнопка [image] которая позволяет выбрать нужный исполняемый файл. По умолчанию внешний аудиоредактор не назначен.

Внешний файловый менеджер - сторковый редактор и кнопка. В строке редактора вы можете ввести путь к исполняемому файлу внешнего файлового менеджера. В некоторых окнах программы есть функция "внешний файловый менеджер" ("Browse"). Эта функция использует команду из этого окна редактора. По умолчанию используется проводник Windiws, но вы можете назначить какой-либо другой, например Windows Commander.
Справа от строкового редактора расположена кнопка [image] которая позволяет выбрать нужный исполняемый файл.

Страница "Разное 1 "

Щелкните мышкой на интересующем вас объекте чтобы получить информацию о нем:

переключатель Устанавливать статус при воспроизведении. Основное назначение поля статуса списка - показать, что песня уже проигрвалась в данном сеансе работы со списком. Если этот переключатель включен, то при старте воспроизведения песни устанавливается поле статуса, в нем появляется символ звездочки * . При этом список считается измененным (поле статуса было изменено!) и в строке состояния программы появляется слово modified - изменен. Если данный выключатель не включен, то прои воспроизведении строки не помечаются как проигранные, то есть поле статуса не изменяется.

переключатель Очищать статус при загрузке списка. Если включена эта функция , то при загрузке списка воспроизведения будет очищаться поле статуса списка, то есть будет считаться, что все песни списка еще небыли проиграны в данном сеансе работы. Если эта функция отключена, то при загрузке списка поле статуса будет в том состоянии, как при последнем сохранения списка.

переключатель Очищать при копировании и вырезании. Если этот режим включен, то при копировании в карман новой информации старая информация стирается (режим работы, аналогичный тому, как работает буфер обмена Windows). Если этот режим отключен, то строки, копируемые в карман будут добавляться к уже имеющимся в кармане.

переключатель Очищать при вставке - Если этот режим включен, то при всавке информации из кармана в список информация в кармане стирается (строки "перемещаются" в список). Если этот режим выключен, то строки просто копируются из кармана в список (режим работы, аналогичный тому, как работает буфер обмена Windows).

переключатель Вставлять ниже курстора - Если этот режим активен, то информация из кармана вставляется в список в позицию строки, ниже текущей. Иначе информация вставляется начиная с позиции текущей строки.

переключатель Авторежим - Включение автоматического режима работы фонового проигрвателя. Дублирует соответствующий выключатель в окне проигрывателя фоновой музыки.

переключатель Случайный - Режим случайного выбора песни из списка фоновой музыки. Дублирует соответствующий выключатель в окне проигрывателя фоновой музыки.

переключатель Проверять списки при загрузке - Есои этот режим включен, то при открытии списка будет производиться прверка строк списка на предмет наличия на диске файлов, на которые ссылаются строки списка. Если обнаружиться, что какой-то файл отсутствует, такая строка будет помечена как ошибочная, в поле Названия песни будет прописано ##NO FILE!## ("отсутствует файл"), а в поле Исполнителя - ##INVALID RECORD## ("Ошибочная запись"). Потом вы можете сами удалить эти строки, либо порытаться вручную найти отсутствующие файлы. Рекомендуется включить эту функцию.

кнопка Связать файлы с Lppro. Данная кнопка запускает функцию, которая осуществляет связывание звуковых файлов типа mp3, wma, ogg, ape, wav а также файла списка lpl с программой Live Performance Pro. Если вы хотите, чтобы можно было воспроизводить указанные типы звуковых файлов в Lppro по умолчанию, при щелчке в проводнике Windows, то выполните этцу фунекцию после инсталляции программы. Эта функуция может пригодиться впоследствии также в том случае, если связь файлов с Lppro будет утеряна из-за ошибки реестра или в результате некорректной работы кактх-либо программ очистки реестра. В таком случае запустите функцию связывания файлов еще раз.
нажмите кнопку "Связать файлы с Lppro". Появится запрос "Вы уверены?", нажмите кнопку "Yes". В результате файлы wav, mp3, wma, ogg, ape, а также файлы списков lpl будут связаны с Lppro.
примечание: при открытии звуковых файлов в Lppro из проводника Windows они будут всегда воспроизводиться в проигрывателе подслушки.

Установка английского языка интерфейса программы. Изменения сразу же вступают в силу. Не требуется нажатие кнопки OK или презапуска программы.

Установка русского языка интерфейса программы. Изменения сразу же вступают в силу. Не требуется нажатие кнопки OK или презапуска программы.

Страница "Разное 2 "

Щелкните на интересующем вас объекте чтобы получить информацию о нем:

Группа переключателей Поверх других окон. Позволяет включить для окон микшера, кармана и фонового проигрывателя такой режим отображения, когда они располагаются всегда поверх остальных окон программы. Этот режим удобен, если вы перетаскиваете файлы мышкой из списков в эти окна.

В программе есть окна, которые ВСЕГДА распологаются поверх других окон программы. Это окно синхронного вывода текста песни (Lyriks) и окно проигрывателя подслушки / файлового браузера.

Цвет фона главного окна - щелчек мыши на этой области открывает диалог, который позволяет выбрать цвет фона главного окна программы.

прерключатель Включить текст. Включает функцию синхронного вывода текста песни (Lyriks). Для работы с Lyriks включите этот переключатель, иначе окно Lyriks будет недоступно.

кнопка Цвет текста - позволяет настроить цвет шрифта окна текста (Lyriks).

кнопка Цвет фона - позволяет настроить цвет фона окна текста (Lyriks).

кнопка Шрифт - позволяет выбрать тип и размер шрифта окна текста (Lyriks).

Sample Text (пример текста) - Здесь можно посмотреть как будет выглядеть текст в окне текста (Lyriks).

страница системных настроек различные настройки 1 различные настройки 2 выключатель режима ватостопа выключатель режима установки громкости из списка выключатель режима установки времени кроссфейда из списка время концевого фейда режим работы кроссфейда включает фейд при нажатии ПЛЭЙ включает фейд при нажатии СТОП Установка времени кроссфейда режим переключения каналов открывает окно редактора огибающей кроссфейда кнопка подтверждения изменений кнопка отмены изменений


win_cf_ed

Редактор огибающей Кроссфейда

Кроссфейд - это процесс плавного перехода одной песни в другую. При этом громкость первой песни плавно уменьшается до нуля в то время, как громкость второй песни увеличивается до максимума. По умолчанию (после инсталляции программы) кроссфейд происходит по линейному закону. Возможно вы захотите изменить параметры огибающей кроссфейда. Это можно сделать в окне редактирования огибающей кроссфейда:

узловая точкаузловая точкаузловая точкаузловая точкаузловая точкаОгибающая кроссфейдаОгибающая кроссфейдаОгибающая кроссфейдаОгибающая кроссфейдаОгибающая кроссфейдаОгибающая кроссфейдаКнопка загрузки кривой с дискаКнопка сохранения кривой на дискеСброс кривой по умолчаниюВыход с сохранением измененийВыход с отменой измененийграфическое представление процесса кроссфейда

На кривой кроссфейда есть пять узловых точек [image]. Перемещая точки при помощи мышки вы можете изменять кривую кроссфейда. В окошке слева (под кнопкой "Сохранить") кривая черного цвета - это процесс уменьшения громкости первой песни, а кривая красного цвета - процесс увеличения громкости второй песни. При редактировании кривой вы всегда изменяете процесс уменьшения громкости, а огибающая увеличения громкости устанавливается автоматически (зеркальное отражение огибающей уменьшения громкости).

Для сохранения огибающей нажмите кнопку "Сохранить", а для загрузки ранее сохраненной кривой нажмите кнопку "Загрузить".

При нажатии кнопки "Сброс" устанавливается линейная огибающая.

Для выхода из редактора с подтверждением изменений нажмите кнопку "ОК".

Для выхода из редактора с отменоной изменений нажмите кнопку "Отмена".


win_mixer

Окно виртуального микшера

Окно виртуального микшера служит для управления устройством основного канала воспроизведения программы. Многие элементы управления микшера продублированы на панели инструментов главного окна.

Окно микшера разделено на две части - первый и второй виртуальные каналы воспроизведения. Оба виртуальных канала работают через одно и то же устройство - устройство основного канала. При автоматическом воспроизведении по списку с включенным кроссфейдом каналы воспроизводят поочередно.

Щелкните на интересующем вас объекте чтобы получить информацию о нем:

меню файла для первого канала открывает окно настроек программы. часы - показывают текущее время меню файла для второго канала закрывает окно виртуального микшера Дисплей времени первого канала Дисплей времени второго канала Индикатор уровня воспроизведения Индикатор уровня воспроизведения Позиция воспроизведения первого канала Позиция воспроизведения второго канала Информационный дисплей первого канала Информационный дисплей второго канала Регулятор громкости первого канала Регулятор громкости второго канала скорость воспроизведения первого канала скорость воспроизведения второго канала Регулятор панорамы первого канала Регулятор панорамы второго канала Кнопки транспорта первого канала Кнопки транспорта второго канала Ручной кроссфейдер регулятор общей громкости основного устройства Старт воспроизведения текущей песни списка пауза воспроизведения по списку (оба канала) Стоп воспроизведения по списку (оба канала) Старт воспроизведения следующей песни

кнопка File первого канала микшера - открывает выпадающее меню для первого виртуального канала микшера:

Из этого меню можно:

1. загрузить звуковой файл непосредственно с диска (минуя список воспроизведения) в данный виртуальный канал.

2. Загрузить список воспроизведения в основное окно программы.

3. Закрыть звуковой файл, загруженный в этот канал.

4. Закрыть звуковые файлы, загруженные в оба канала.

5. Получить информацию о звуковом файле.

кнопка File второго канала микшера - открывает выпадающее меню для второго виртуального канала микшера:

Из этого меню можно:

1. загрузить звуковой файл непосредственно с диска (минуя список воспроизведения) в данный виртуальный канал.

2. Загрузить список воспроизведения в основное окно программы.

3. Закрыть звуковой файл, загруженный в этот канал.

4. Закрыть звуковые файлы, загруженные в оба канала.

5. Получить информацию о звуковом файле.

Дисплей времени канала. Во время воспроизведения он отображает, прошедшее с начала воспроизведения песни, либо оставшееся до конца воспроизведения время в данном канале. переключаться между этими режимами можно щелкая мышкой на дисплее.

Индикаторы уровня воспроизведения - во время воспроизведения отображают уровень сигнала.

Полоса бытрого поиска по файлу. Графически отображает текущую позицию воспроизведения файла в данном канале. Для перехода к нужному месту песни щелкните на соотв. участке полоски.

Информационный дисплей канала. Сюда выводится название песни (из списка или из id3-тега 'Title' если песня загружается с диска минуя список), имя файла и продолжительность звучания. Даойной щелчок на информационнном дсиплее открывает окно подробной информации о файле, загруженном в данный канал.

Регулятор громкости канала. Если включер режим громкость из списка, то уровень громкости канала устанавливается автоматически при занрузке песни и значение громкости берется из соответствующего (скрытого) поля списка.

Регулятор эффекта Jog канала. Замедляет или ускоряет воспроизведение. Аналог изменения скорости движения ленты в магнитофоне. Когда вы отпускаете мышку, скорость воспроизведения возвращается к нормальной. Для того, чтобы зафиксировать измененную скорость, щелкните мышкой на полоске регулятора Jog, одновременно удерживая нажатой клавишу Ctrl. Для того, чтобы вернуться к норматьной скорости, еще раз щелкните мышкой на регуляторе.

Регулятор стереопанорамы канала. Для того, чтобы установить панораму в центральное положение, щелкните мышкой на надписи pan желтого цвета справа от регулятора.

Группа кнопок транспорта канала. Влияет на воспроихведение только данного канала.

Кнопка Плэй. запускает воспроизведение файла, загруженного в данный канал микшера.

Кнопка Пауза. Временная остановка воспроизведения файла, загруженного в данный канал микшера.

Кнопка Стоп. Остановка воспроизведения файла, загруженного в данный канал микшера.

Кнопка Концевого Затухания (Фейда). Поавное уменьшение громкости канала и остановка воспроизведения файла, загруженного в данный канал микшера.

Кроссфейдер - Движок ручного кроссфейда. В режиме ручного кроссфейда позволяет регулировать баланс громкости между виртуальными каналами микшера. В режиме Старта по Фейдеру перемещение этого движка запускает и остананвливает воспроизведение виртуальных каналов.

Регулятор общей громкости виртуального микшера. Дублирует соответствующий регулятор на инструментальной панели главного окна.


win_reh

окно проигрывателя подслушки - файлового браузера

Данное окно - самостоятельный проигрыватель, который можно назначить на отдельное звуковое устройство. Проигрыватель подстушки совмещен с небольшим файловым менеджером, в котором вы можете перемещаться по дискам и файлам, прослушивать звуковые файлы и помещать их в списки, получить информацию о звуковом файле. Вы также можете скопировать файлы в какую-либо папку или удалять файлы с жесткого диска (удаленные файлы помещаются в "корзину" на рабочем столе Windows).

время звучания песни, оставшееся и прошедшее время. имя файла или название загруженной песни индикатор уровня воспроизведения Полоса поиска по файлу. Регулятор громкости подслушки Кнопка плэй Кнопка Пауза Кнопка Стоп Кнопка проиграть из списка Кнопка открыть с диска Кнопка добавить Кнопка сканировать и найти файлы Скопировать файл в папку удалить файл в корзину Кнопки Назад и Вперед Открывает окно Избранных папок Переключает в компактный режим интерфейса открывает окно настроек программы Выбор диска выбор папки Выбор конкретного файла текущая маска файла. Левая кнопка мышки - открывается окно ввода маски Правая кновка мышки для выбора предустановок. Ctrl+левая кнопка - маска по умолчанию (звуковые файлы)

Вы можете прослушивать файлы на диске и из списков через наушники, подключенные к отдельной звуковой карте и одновременно "крутить" дискотеку через основную звуковую карту. Это очень удобно, когда вам необходимо выбрать, какую же песню поставить следующей во время проигрывания какой-то другой песни. Это равноситьно тому, что у вас под рукой всегда как бы два CD-плеера. Через один вы работаете на зал, а в другом ищите хорошие песни. Только гораздо удобнее... Кроме того одновременно с этим может воспроизводить еще и проигрыватель фоновой музыки. Если он назначен на третье отдельное звуковое устройство, то ваш компьютер может озвучивать, например, соседний зал ресторана.
Кроме того, вы можете загружать списки воспроизведения Lppro, открывать текстовые файлы (файлы с расширением *.txt), которые открываются в редакторе текстов песен (Lyriks). Из окна файлового менеджера (браузера) Lppro вы даже можете запускать другие программы.

В программе имеется Компактный режим интерфейса - такой режим работы, при котором экономится экранное пространчтво. При этом большое главное окно со всеми окнами списков убирается с экрана (но списки при этом не закрываютя). На экране остается только окно проигрывателя подслушки. Переключиться в компактный режим и обратно, можно нажав клавишу F11 либо щелкнув мышкой на кнопке [image] на панели инструментов окна подслушки или главного окна.

При перемещении по дискам и папкам все ваши действия запоминаются и вы можете возвращаться назад и прерходить вперед как вы это делаете, например, при путешествии по Интернету. Для этого служат кнопки [image] (назад / вперед).

Есть также возможность запомнить часто посещаемые папки на ваших дисках, как избранные папки. Для помещения какой-либо папки в избранное, нажмите Ctrl+D, находясь в этой папке. Окно со списком избранных папок открывается щелчком по кнопке [image] .

Если вы запускаете файл на воспроизведение из проводника Windows, то он открывается именно в проигрывателе подслушки.

Заголовок окна. При воспроизведении файла здесь отображается три группы цифр:

Время звучания песни - Прошедшее время - оставшееся время.

Например:

Индикаторы уровня воспроизведения - во время воспроизведения отображают уровень сигнала.

Дисплей названия песни. Здесь показвается название или имя файла воспроизводимой в подслушке песни.

Полоса бытрого поиска по файлу. Графически отображает текущую позицию воспроизведения файла в данном канале. Для перехода к нужному месту песни щелкните на соотв. участке полоски.

Регулятор громкости подслушки. Воздействует только на громкость проигрывателя подслушки.

Кнопка Проиграть из Списка - Загружает в проигрыватель подслушки и включает на воспроизведение текущую песню из текущего списка воспроизведения.

Кнопка загрузки файла с диска. Удобнее пользоваться для этого встроенным файловым браузером этого окна.

Кнопка Добавить в список - Нажатие на эту кнопку добавит в текущий список файл, открытый в проигрывателе подслушки.

Поиск и добавление файлов. Позволяет добавлять файлы в список одновременно из нескольких вложенных папок. Например, вы можете добавить в список все файлы *.wav, которые есть на вашем диске С:. Функция может искать файлы определнного типа или какой-то один определенный файл. Открывается специальное окно. При этом устанавливается та папка, которая открыта в файловом браузере в момент вызова этой функции. Подробно смотрите в разделе Окно сканирования папок, поиска и добавления файлов.

Кнопка Копировать. Позволяет скопировать текущий файл в какую-либо другую папку. Функция очень удобна при прослушивании большого количества звуковых файлов (например, сэмплов инструментов) с целью выбрать из них нужные и скопировать куда-нибудь в одно место.

Кнопка Удалить.Отправляет файл в корзину.

Кнопки Вперед и Назад. Когда вы перемещаетесь по папкам и дискам с помощью файлоаого браузера этого окна, программа создает список истории, где запоминает ваши действия. Вы можете вернуться на несколько шагов назад или вперед с помощью этих кнопок (как в web - браузере).

Кнопка Избранное. Открывает окно менеджера избранных папок. Вы можете добавить в избранное любую папку, которую вы часто используете, чтобы в последствии быстро к ней перейти. Добавить папку в избранное можно нажав Ctrl+D на клавиатуре или из окна окно менеджера избранных папок. Для того, чтобы перейти к какой - либо папке из списка избранных, откройте окно менеджера избранных папок и давжды щелкните на нужной папке.

Кнопка переключения в компактный режим - такой режим работы, при котором экономится экранное пространчтво. При этом большое главное окно со всеми окнами списков убирается с экрана (но списки при этом не закрываютя). На экране остается только окно проигрывателя подслушки. Переключиться в компактный режим и обратно можно также нажав клавишу F11.

Эта кнопка открывает оено настроек программы.

Окно выбора текущего диска. Позволяет выбрать сменить текущий диск.

Окно выбора текущей папки . Позволяет выбрать сменить текущую папку. Окно выбора текущей папки имеет свое собственное выпадаюшее меню. Для вызова этого меню, нажмите наи этом окне правую кнопку мышки. Появится такое меню:
вернуться на один шаг назад На один шаг вперед откроет папку файлом в проводнике Добавляет текущую папку в избранное Открывает окно менеджера избранных папок
Для получения дополнительной информации, на секунду задержите мышку над строкой меню на этом рисунке.

Окно файлов . Позволяет выбрать файл. Из этого окна вы можете перетаскивать файлы (без нажатия Ctrl) в окна списков, воспроизводить в устройстве подслушки (двойной щелчок). Выделенный здесь файл может быть скопирован или удален. Вы можете получить информацию о выделенном файле, выделив файл и нажав клавишу i . Вы можете также открывать текстовые файлы и запускать программы.
Окно файлов имеет свое собственное выпадаюшее меню. Для вызова этого меню, нажмите наи этом окне правую кнопку мышки. Появится такое меню:
Проигрывает выделенный файл в подслушке Добавит в список выделенный файл Выводит подробную информацию о файле откроет папку с выделенным файлом в проводнике Позволяет изменить маску файлов для этого окна Копирует файл в какую-либо папку Удаляет файл в корзину Добавляет текущую папку в избранное Открывает окно менеджера избранных папок Открывает редактор текста песни для выделенного файла
Для получения дополнительной информации, на секунду задержите мышку над строкой меню на этом рисунке.


win_favorites

окно менеджера избранных папок

Щелкните мышкой на интересующем объекте

Кнопка Добавить. Позволяет добавить текущую папку в список избранных. Если папка с таким путем и именем уже есть в списке, то будет выведено соответствующее сообщение и в окне списка папок будет выделена эта папка.

Кнопка Удалить. Удаляет из списка избранных выделенную папку.

Кнопка Перейти. Открывает выделенную папку в браузере файлов. То же самое, что двойной щелчок на имени папки в списке избранных.

переключатель Путь. Если отключен, то в окне списка папок показваются только их имена. Если вы включите переключатель, то в окне списка папок будут показываться имена папок с полным путем их поиска.

Кнопка Закрыть. Закрывает окно менеджера избранных папок

Окно списка избранных папок. Для перехода к нужной папке, дважды щелкните мышкой на имени папки (или выделите папку одинарным щелчком и нажмите кнопку Перейти)

В этом оошке показвается имя выделенной папки с полным путем поиска.


win_info

Окно информации о файле / редактирования тэгов mp3-файла.

Окно служит для вывода информации о звуковом файле и для изменения ID3-тэгов данного файла, в том случае, если это mp3-файл.

Окно разделено на две части. В левой части выводится информация о текущем файле. Количество информационных строк в этой области окна зависит от типа файла и от того, откуда вызвано окно информации. Если запрашивается информация о файле из списка воспроизведения, то выводится также название песни, исполнитель и темп (информация извлекается из соответствующих полей списка воспроизведения).

Правая часть окна активизируется только в том случае, если это Mp3 - файл. При этом в правой части окна выводится информация, записанная в тэгах файла. Вы можете ввести новую информацию и нажать кнопку "Записать тэги". Новая информация будет записана в тэги Mp3 - файла.

Внимание! Если файл, в котором вы хотите переписать тэги, в данный момент воспроизводится либо просто открыт в каком-либо из устройств-проигрывателей LPPro (или в какой-то другой программе), то тэги не могут быть переписаны. (появится сообщение "Ошибка сохранения тэгов id3. Возможно файл открыт в LPPro или в другой программе")В этом случае закройте аудиофайл, потом попытайтесь записать теги снова.

Ниже приведен перевод заголовков информационных строк окна:

Левая часть окна (информация о файле):

Play List - отображается только если окно информации вызвано из списка воспроизведения. В этой строке выводится имя файла списка, в котором находится ссылка на данный файл.

Disk - отображается только если окно информации вызвано из окна файлового браузера - подслушки.

File Name - имя файла.

Directory - Путь к файлу.

Size - Размер файла в килобайтах и мегабайтах.

List Title - Название песни -только при вызове из списка.

List Artist - Исполнитель - только при вызове из списка.

Duration - Продолжительность песни чч:мм:сс

BPM - Темп песни - только при вызове из списка.

Format - Формат звукового файла.

S.Freq - Чачтота дискретизации (сэмплирования) файла.

Bits - Цифровое разрешение аудиофайла (бит).

Bitrate - для mp3 файла - плотность потока данных кбит/сек.

Ch.Mode - моно / стерео.

Правая часть окна - тэги mp3 файла.

Title - Тэг названия песни

Artist - Тэг исполнителя

Year - Год

Album - Название альбома

Track - Номер трека

Comment - комментарии


win_bg

Проигрватель фоновой музыки

Проигрыватель фоновой музыки - это дополнительный проигрыватель, основное назначение которого - заполнение фоновой музыкой пауз в звучании основного устройства. Выход проигрывателя фоновой музыки может быть назначен на отделное звуковое устройство. Вы можете использовать этот проигрыватель по его прямому назначению - для заполнения пауз. Другой вариант - это направить выход фонового проигрывателя на отделную звуковую карту, подключенную к отдельному усилителю и акустическим системам. Тогда вы, к примеру, можете проводить дискотеку в одном зале ресторана, и в то же самое время фоновый проигрыватель будет озвучивать другое помещение, например, второй зал ресторана.

Как работает фоновый проигрыватель?

- Предположим, что вы - певец и работаете в ресторане под минусовки. У вас есть некий список воспроизведения с вашими фонограммами.

- У вас есть некоторый список воспроизведения с фоновой музыкой, загруженый в фоновый проигрыватель.

- Включите автоматический режим работы фонового проигрывателя. Для этого установите галочку с надвисью "Автом." на инструментальной панели проигрывателя.

- Можете включить режим случайного выбора песни - галочка "Случайно" на инструментальной панели проигрывателя.

- Дважды щелкните на первой песне списка или нажмите кнопку "плэй" - [image]. Начнется воспроизведение фоновой музыки.

- Регулятором громкости в правой части окна проигрвателя (см. рисунок ) установите желаемую громкость воспроизведения фоновой музыки.

- Если теперь вы запустите какую-либо песню в вашем основном списке, то громкость фоновой музыки плавно уменьшится до нуля, и только после этого начнет воспроизводиться ваша минусовка. При этом фоновый проигрыватель НЕ останавливает воспроизведение. Его громкость просто выводится до нуля. Когда вы остановите воспроизведение минусовки в основном устройстве (или она остановится сама, если включен режим "автостоп"), то громкость фоновой музыки плавно увеличится до уровня, который вы до этого установили. Таким образом исключается ситуация "тишины в зале".

- Вы можете установить время нарастания и спада громкости фоновой музыки (в секундах).

Работа со списком в фоновом проигрывателе.

- Вы можете создать список воспроизведения обычным орбразом в главном окне программы, сохранить его на жестком диске, и потом загрузить в фоновый пригрыватель и использовать в качестве списка фоновой музыки.

- Вы можете создать новый список и сохранять его на диске прямо из окна фонового проигрывателя. Добавить файлы в фоновый список можно несколькими способами:

1. Нажать кнопку [image] добавления файлов на инструментальной панели окна фонового проигрывателя, затем выбрать папку и бобавляемые файлы.

2. Перетащить мышкой файл из списка воспроизведения в главном окне программы.

3. Перетащить мышкой файл из окна файлового браузера/подслушки.

* Все операции перетаскивания мышкой ИЗ списка воспроизведения осуществляются с нажатой клавишой Ctrl.

- После того, как вы добавили файлы в список фонового проигрывателя, можете сохранить его на диске, нажав кнопку [image] сохранения файлов на инструментальной панели окна фонового проигрывателя. Сохраненный список имеет тот же формат, что и любой другой список воспроизведения Lppro и может быть загружен в главном окне программы как список воспроизведения.

- Для того чтобы загрузить список в проигрыватель подслушки, нажмите кнопку кнопку [image] загрузки файлов на инструментальной панели окна фонового проигрывателя.

Элементы управления окна фонового проигрывателя.

Для того, чтобы получить информацию о каком-либо элементе управления окна, щелкните на нем мышкой:

индикатор уровня воспроизведения кнопка очистки списка кнопка открытия списка кнопка сохранения списка кнопка добавления файлов кнопка удаления строки активизвция увеличения громкости установка времени изменения громкости кнопка активизации уменьшения громкости вызов окна настроек программы режим автоматической фоновой музыки случайный выбор из списка громкость фоновой музыки список фоновой музыки позиция воспроизведения Плэй, пауза, стоп панорама строка состояния
Окно фонового проигрывателя.

индикатор уровня воспроизведения - показывает уровень сигнала во время воспроизведения фоновой музыки.

кнопка "Новый список" - очищает текущий список.

кнопка "Открыть список" - позволяет загрузить в фоновфй проигрыватель файл списка воспроизведения с жесткого диска.

кнопка "Сохранить список" - позволяет сохранить файл списка воспроизведения на жестком диске.

кнопка "Добавить" - позволяет пополнять список, добавляя в него новые звуковые файлы.

кнопка "Удалить" - удаляет из списка вылеленную строку.

кнопка позволяет вручную запустить процесс увеличения громкости фоновой музыки.

Этот орган управления позволяет установить время нарастания (левое окошко) и спада громкости (правое окошко) фоновой музыки. Красная вертикальная полоска посередине отображает процесс изменения громкости. Время устанавливается в секундах.

кнопка позволяет вручную запустить процесс уменьшения громкости фоновой музыки.

кнопка позволяет открыть окно настроек программы.

переключатель позволяет включить режим автоматической работы фонового проигрывателя.

Если установлена галочка этого переключателя, то в процессе воспроизведения производится случайный ывбор песни из списка.

Список фоновой музыки. Сначала идет порядковый номер песни. Затем название песни или имя файла, затем время звучания песни. Вы можете изменять порядок следования песен в списке, перетаскивая строки мышкой вверх или вниз. Двойной щелчок на строке запускает воспроизведение песни.

Регулятор громкости фоновой музыки. Независимый регулятор - влияет только на громкость фоновой музыки, даже если фоновая музыка назначена на то же самое аудиоустройство, что и основной канал.

Полоса поиска - графически отображает позицию времени воспроизведения. Для перехода к определенному месту в песне, щелкните на наужном месте полоски.

Кнопка "плэй" - нажмите для начала воспроизведения фоновой музыки.
Кнопка "Пауза" - нажмите для паузы воспроизведения фоновой музыки.
Кнопка "Стоп" - останавливает воспроизведение фоновой музыки.

регулятор панорамы и кнопочка "pan". Нажатие на "pan" установит ранораму в центр.

Строка состояния фонового проигрывателя. Слева направо отображаются: Количество строк в списке, суммарное время звучания списка фоновой музыки, порядковый номер песни и ее название.


win_lyriks

Окно синхронного вывода текста песни (Lyriks)

См. также:

Работа с текстами песен в LPPro.
 Окно редактора текста песни (Lyriks)

Окно вывода текста песни предназначено для синхронного вывода текста песни во время воспроизведения.

Для работы функции вывода текста песни необходимо, чтобы в той папке, где расположен звуковой файл, находился также текстовый файл со словами песни. Текстовый файл должен иметь то же имя, что и звуковой файл, но его расширение должно быть ".txt". Как создать текстовый файл со словами песни см. здесь>>.

Для того, чтобы вывод текста песни происходил синхронно с процессом воспроизведения, текст песни должен быть соответствующим образом размечен>>. В том случае, если текст не будет размечен, при старте песни будет выведен весь текст целиком.

Окно вывода текста песни всегда распологается поверх главного окна программы и окон списков воспроизведения. Окно может быть развернуто на весь экран. При этом в окне вывода текста имеются кнопки управления воспроизведением по списку (Старт, Стоп, Старт Следующую) и регулятор общей громкости основного устройства (виртуального микшера).

Для получения информации об элементе управления окна, щелкните на нем мышкой:

Описание элементов управления окна вывода текста песни.

- Кнопка "Показать все" - при нажатии этой кнопки будет показан полный текст песни вместе со строками точек разметки.

- Обновление содержимого окна вывода песни.

- откроет окно редактора текста песни для текущего звукового файла.

- переход к предыдущей или следующей точке - маркеру.

Выпадающий список точек разметки. Показывается номер точки, название (комментарий) и время в формате Часы:Минуты:Секунды.

- Кнопки управления воспроизведением из списка. Дублируют соответствующие кнопки на панели инструментов главного окна программы. Полезны, если окно вывода текста песни развернуто на весь экран и закрывает собой главное окно программы.

- Открывает окно настроек.

- Регулятор общей громкости основного устройства. Дублирует регулятор громкости главного окна программы.


win_lyriks_ed

Редактор текста песни (Lyriks)

См. также:

Работа с текстами песен в LPPro.
 Окно синхронного выводв текста песни (Lyriks)

Редактор текста песни - это специализированный текстовый редактор, интегрированный в программу LPPro. Редактор совмещенн с аудиопроигрывателем. Воспроизведение осуществляется через аудиоустройство подслушки.
Окно редактора показано на рисунке. Для того, чтобы получить информацию о каком-либо элементе окна, щелкните на нем левой кнопкой мышки.

раздел меню Файлраздел меню Управлениераздел меню УправлениеТОЧКА - маркер времениТОЧКА - маркер времениТекст песниТОЧКА - маркер времениТекст песниТОЧКА - маркер времениТекст песниТекст песни

Окно редактора разделено на две части. Левая часть окна предназначена для редактирования и разметки текста песни. В правой части окна выводится текст песни так, как он отображается в окне синхронного вывода текста песни. Это дает возможность контролировать правильность разметки текста, не выходя из редактора. Размеры левой и правой части можно изменять, перетаскивая мышкой границу влево или вправо. В нижней части окна редактора расположена строка состояния, в которой отображается следующая информация: индикация того, что текст был изменен, количество точек времени в тексте, значение времени текущей точки в милисекундах, значение времени текущей точки в формате "Часы:Минуты:Секунды".

Данный текстовый редактор предназначен для создания и разметки текстового файла со словами песни (Lyriks), тем не менее, в данном редакторе можно открывать и редактировать любой текстовый файл в кодировке Windows.

Создание текстового файла Lyriks (слов песни).

Текст песни (Lyriks) может быть создан для любого звукового файла. Файл Lyriks - это обычный текстовый файл с расширением *.txt. При этом имя текстового файла должно совпадать с именем соответствующего звукового файла. Напрмер у нас есть звуковой файл valsboston.mp3, тогда файл со словами для это песни должен иметь имя valsboston.txt. Кроме того, чтобы программа смогла найти файл с текстом песни, он должен распологаться в ТОЙ ЖЕ папке, что и соответствующий ему звуковой файл.

Когда вы создаете файл текста песни для конкретного звукового файла, то вам не нужно беспокоиться об имени текствого файла и его расположении. Программа все сделает автоматически.

Когда вы открываете окно редактора (клавиша F4), то программа пытается найти текстовый файл, соответствующий текущему аудиофайлу (в выделенной строке списка воспроизведения). Если файл найден, то он открывается в редакторе. В том случае, если файл не найден, то в памяти компьютера создается новый текстовый файл с именем, соответствующим звуковому файлу и с расширением TXT. Если вы теперь нажмете кнопку [image] ("сохранить") на панели инструментов редактора, то текстовый файл будет сохранен на диске в той же папке, где распологается соответствующий ему звуковой файл.

Таким образом, для того, чтобы создать пустой текствый файл Lyriks достаточно выделить нужную песню в списке, открыть редактор текста песни и на его панели инструментов нажать кнопку [image].

Созданный файл Lyriks будет пуст. Вы должны будете напечатать текст песни, либо скопировать его из другого редактора через буфер обмена Windows.

Разметка текста. Порядок работы.

Для успешного автоматического вывода слов песни текст должен быть размечен оперделенным образом. Разметка осуществляется вставкой в текст строки с определенной последовательностью символов. Такая метка называется точкой времени и вставляется в текст песни нажатием кнопки [image] на панели инструментов редактора, или сочетанием клавиш Ctrl+i на клавиатуре. Удалить какую либо точку времени можно просто стерев ее как обычный текст. Точка жестко привязана к определенной временной позиции воспроизведения песни. Во время воспроизведения на экран будет выведен текст в тот момент, когда позиция воспроизведения песни достигнет времени, заданного в данной точке. При этом будет показан участок текста от данной точки до следующей (или до конца текста, если это последняя точка). таким образом, чтобы начать показ текста с самого начала, нужно вставить точку перед началом текста.

Формат строки точки времени:

<#####/комментарий>

< - обозначает начало текста точки времени.

##### - число, обозначающее время момента вывода на экран текста, следующего за точкой времени. Время отсчитывается от начала воспроизведения песни и задается в миллисекундах (1 секунда = 1000 миллисекунд).

/ - разделяющий символ.

комментарий - вы можете написать комментарий к точке, например: <26495/1 куплет>. "26495" - это время точки, а "1 куплет" - это комментарий. Комментарий можно не задавать, но разделяющий символ " /" должен оставаться. Тогда текст точки времени будет выглядеть следующим образом: <26495/>.

> - обозначает окончание текста точки времени.

Возможный порядок работы при разметке текста.

1. Напечатайте текст песни в левой части окна редактора (или скопируйте из другого редактора через буфер обмена Windows). Предположим, что это песня Антонова "20 лет спустя", как это изображено на рисунке выше.

2. Убедитесь в том, что проигрыватель окна редактора находится в состоянии "Стоп", а позиция воспроизведения равна или близка к нулю (время отображается в средней части полосы поиска по файлу в верхней части окна):

3. Вставте первую точку времени в начало текста песни. Для этого, в левой части окна редактора, поместите курсор ввода текста в начало первой строки текста (у нас это - название песни) и нажмите на клавиатуре Ctrl+i или кнопку [image] на панели инструментов редактора. В начало текста будет вставлена точка с параметрами <0/>. Теперь при старте воспроизведения песни в окно синхронного вывода Lyriks будет выведено название песни.

4. Запустите воспроизведение песни, нажав кнопку [image] на панели инструментов редактора. Начнется воспроизведение фонограммы через устройство подслушки.

5. Теперь нам нужно вставить точку, соответствующую началу куплета песни. Для этого, прослушивая песню, остановите воспроизведение в нужном месте, нажав кнопку ПАУЗА [image] на панели инструментов. При необходимости откорректируйте позицию, перемещая полосу посика по песне мышкой и запуская и останавливая воспроизведение (вы можете втсавлять точки и на ходу - не останавливая воспроизведения кнопкой паузы). После того, как вы остановите воспроизведение в нужной точке, установите курсор текста в начало первой строки первого куплета и снова нажмите на клавиатуре Ctrl+i или кнопку [image] на панели инструментов редактора. Будет вставлена точка времени, например такая (у вас, скорее всего, будет другое значение времени):

<26495/>

установите текстовый курсор в позицию между символом разделителя "/" и ">" и впечатайте примечание, например "Куплет 1". Точка времени будет выглядеть примерно так:

<26495/Куплет 1>

Вы можете вручную откорректировать время точки, вводя другое число. При этом нужно иметь в виду, что время выставляется в миллисекундах. Одна секунда равнвна 1000 миллисекундам. Таким образом, чтобы в нашем примере сдвинуть точку на 1 секунду к началу песни, вместо числа 26495 нужно ввести число 25495.

6. Повторяя действия пунктов 4 и 5 расставьте другие точки времени.

7. Сохраните текстовый файл, нажав на панели инструментов нажать кнопку [image] или Ctrl+S на клавиатуре. Файл будет сохранен на диске, и будет выведено сообщение об успешном сохранении файла.

Описание элементов управления окна редактора.

Раздел меню "Файл"

Новый текстовый файл - уничтожает сожержимое окна редактора и создает новый текстовый файл.

Открыть текстовый файл - позволяет открыть в редакторе произвольный текстовый файл.

Сохранить текстовый файл - сохраняет на диске текущий текстовый файл.

Cохранить текстовый файл с новым именем - Сохранение файла с произвольным именем. По умолчанию файл имеет то же имя, что и соответствующий ему аудиофайл и расширение TXT. Однако вы можете задать другое имя (не рекомендуется для файлов текстов песен, связанных с аудиофайлами).

Открыть аудиофайл - производит действия, аналогичные тем, что происходят при вызове редактора для сторки списка. В проигрыватель редактора загружается звуковой файл, при этом ищется соответствующий ему текстовый файл со словами песни. Если файл не найден, то создается новый текстовый файл с именем, совпадающим с именем звукового файла, но расширением TXT. Если файл найден, то он открывается для редактирования.

Проводник Windows - Открывается папка, в которой расположен текущий аудиофайл и файл текста песни.

Раздел меню "Управление"

Перейти к следующей точке - переход позиции времени воспроизведения к следующей точке - маркеру. В правой части окна редактора будет выведен текст песни, соответствующий этой точке.

Перейти к предыдущей точке - переход позиции времени воспроизведения к предыдущей точке - маркеру. В правой части окна редактора будет выведен текст песни, соответствующий этой точке.

Воспроизведение - Пауза - Стоп - Кнопки управления проигрывателем редактора.

Раздел меню "Редактирование"

Вставить точку - вставка точки-маркера в позицию курсора и со значением времени, соответствующем текущему времени воспроизведения.

Отменить - отменяет последнюю операцию с текстом.

Удалить все точки - удаляет все строки, содержащие точки-маркеры.

Вырезать - вырезает выделенный текст и помещает его в буфер обмена.

Копировать - копирует выделенный текст в буфер обмена.

Вставить - вставляет текст из буфера обмена в позицию курсора.

Font - позвлояет настроить параметры шрифта окна редактора.

Обновить окно текста песни - Обновляет окно вывода текста песни в соответствии с изменениями, сделанными в редакторе.

Панель инструментов окна редактора

- уничтожает сожержимое окна редактора и создает новый текстовый файл.

- позволяет открыть в редакторе произвольный текстовый файл.

- сохраняет на диске текущий текстовый файл.

- Сохранение файла с произвольным именем. По умолчанию файл имеет то же имя, что и соответствующий ему аудиофайл и расширение TXT. Однако вы можете задать другое имя (не рекомендуется для файлов текстов песен, связанных с аудиофайлами).

, [image], [image] - Воспроизведение - Пауза - Стоп - Кнопки управления проигрывателем редактора.

- отменяет последнюю операцию с текстом.

- вставка точки-маркера в позицию курсора и со значением времени, соответствующем текущему времени воспроизведения.

- переход к предыдущей или следующей точке - маркеру.

- выпадающий список всех точек данного файла. Показывается номер точки, время точки в миллисекундах, комментарий к точке.

- кнопка вызова окна настроек программы.

- Полоса поиска по файлу. - Графически отображает текущую позицию времени воспроизведения. В средней части полосы показывается время в миллисекундах и в формате часы:минуты:секунды. Служит для бысторй установки нужной позиции при помощи мышки.

Регулятор громкости (устройство подслушки)

Строка состояния окна редактора текста песни.

- в этом поле сторки состояния слово Modified означает, что ткест был изменен.

- Здесь отображается общее количество точек-маркеров в тексте песни.

- знечение времени текущей точки в миллисекундах.

- знечение времени текущей точки в формате часы:минуты:секунды.


win_Scan

Окно сканирования папок, поиска и добавления файлов

По сути данная функция осуществляет поиск файлов на диске по указанному вами пути. Найденные звуковые файлы могут быть прослушаны, не выходя из этого окна, в встроенном проигрывателе. Встроенный проигрыватель воспроизводит через устройство подслушки. Далее вы можете выбрать нужные среди найденных файлов и добавить их в список воспроизведния.

Вы можете осущетсявлять поиск файлов по их расширению, или по любому шаблону. Для быстрого ввода шаблонов поиска звуковых файлов миеются четыре кнопки с расширенями наиболее часто употребляемых звуковых файлов: *.mp3, *.wav, *.ape, *.ogg. При нажатии на одну из этих кнопок в поле ввода шаблона поиска будетт вставлен соответствующий шаблон расширения файла. Символ звездочки (*) означает, что здесь могут находиться любые символы. То есть шаблон *.mp3 означает, что будут найдены все файлы, имеющие расширение mp3, находящиеся в указанной вами папке (и во вложенных в нее папках, если установлен флажок "Subfolders").

Данная функция предназанчена для поиска звуковых файлов, но в принципе, может искать любые файлы по заданному шаблону.

Вот некоторые примеры шаблонов поиска:

*.* - в список найденных файлов будут помещены ВСЕ файлы(с любым именем и любым расширением), расположенные в указанной папке и во вложенных в нее папках.

*.wav - в список найденных файлов будут помещены все файлы, имеющие расширение wav, расположенные в указанной папке и во вложенных в нее папках.

a*.mp3 - в список найденных файлов будут помещены все файлы, имеющие расширение mp3 и имя которых начинается с буквы "a",расположенные в указанной папке и во вложенных в нее папках. Например, "abrakadabra.mp3".

*ti*.*g - в список найденных файлов будут помещены файлы, в имени которых имеется сочетание букв "ti", и расширение которых заканчиывется нв букву "g". Например файл с миенем "plotik.ogg".
И так далее.

Рис. окно сканирования и поиска файлов. Щелкните мышкой на интересующем элементе:

Список найденных файловОбласть отметки файловУправление проигрывателембыстрый поиск по файлуПоле ввода шаблона поискаКнопки предустановок шаблоновПоиск во вложенных папкахПоле ввода пути Выбор папки для поискаНачало поискаПрерывание поискаДобавить найденное в списокСоздать новый список и добавить в него файлырегулятор громкостиЗакрыть это окноКоличество найденных файловНомер текущего файла в списке найденных

Порядок работы с окном поиска и добавления файлов:

1. Введите шаблон поиска в предназначенное для этого поле редактирования. Для быстрого ввода стандартных шаблонов просто щелкните на одной из кнопок *.mp3, *.wav, *.ape, *.ogg.

2. Если вы хотите, чтобы поиск осуществлялся не только в указанной вами папке, но и во ВСЕХ вложенных в нее папках, установите флажок "subfolders" (он установлен по умолчанию).

3. В стедующей строке редактирования введите путь к папке, в которой вы хотите искать файлы. Наиболее просто это сделать нажав кнопку [image], расположенную справа. Откроется диалоговое окно выбора папки, где вы сможете выбрать нужную вым папку. путь к этой папке будет автоматически помещен в поле редактирования.

4. Нажмите кнопку "Старт". Начнется процесс поиска. Процесс поиска может занять довольно продолжительное время. Затянувшийся процесс можно прервать, нажав на кнопку "Стоп".

5. По окончании процесса поиска будет создан список найденных файлов. Каждая сторка в этом списке может быть помечена флажком в начале строки. По умолчанию (после окончания поиска) все строки помечены. Вы можете снять отметку строки, щелкнув мышкой на области флажка в начале строки. В список воспроизведения будут добавлены только отмеченные флажком файлы.
Вы можете прослушать файл, не выходя из окна поиска. для этого ммеется встроенный в окно проигрыватель. Для начала воспроизведения дважды щелкните на нужной строке, либо нажмите кнопку [image]. Громкость воспроизведения можно настроить регулятором у правой границы окна. Проигрывание осуществляется через устройство подслушки.

6. Когда вы выбрали (отметили флажками) те файлы, которые вы хотите добавить в список воспроизведения, вы можете нажать кнопку "Добавить" или "Создать новый".
Если вы нажмете кнопку "Добавить", то отмеченные вами файлы будут добавлены в список воспроизведения, который был текущим в момент открытия окна поиска и добавления файлов.
Если вы нажмете кнопку "Создать новый", то будет создан новый пустой список воспроизведения и в него добавляются все отмеченные строки.

Выпадающее меню окна поиска и добавления файлов.

Нажатие правой кнопки мышки на области списка найденых файлов откроет выпадающее меню с несколькими функциями работы с этим списком:

- Пометить все - устанавливает флажки для всех строк найденных файлов.

- Снять отметку во всех - убиранет флажки для всех строк найденных файлов.

- Иивертировать отметки у всех - Убирает флажки там где они были и устанавливает там, где их небыло.

- Воспроизвести - начинает проигрывание файла во встроенном в окно проигрывателе (через устройство подслушки).

- Добавить в текущий список - добавляет все отмеченные строки (у которых установлены флажки) в список воспроизведения, который был текущим в момент открытия окна поиска и добавления файлов.

- Создать новый список - Создается новый пустой список воспроизведения и в него добавляются все отмеченные строки (у которых установлены флажки).

Органы управления окна поиска и добавления файлов

Список найденных файлов - сюда помещаются найденные файлы.

Щелкнув на этой области списка можно установить или убрать флажок отметки у соответствующей строки. В список воспроизведения будут добавлены только файлы, помеченные флажком.

- Кнопки Плэй, Пауза и Стоп - управление встроенным проигрывателем.

- Полоса поиска по файлу. Графически отображает позицию времени воспроизведения файла и позволяет быстро перейти к нужному участку.

- Поле ввода шаблна поиска - сюда вы должны ввести шаблон, по которому будет производиться поиск файлов. Символ звездочки (*) обозначает любуб последовательность символов в этой позиции.

- Кнопки быстрого ввода заготовок шаблонов (расширений файлов *.mp3, *.wav, *.ape и *.ogg*).

- Выключатель "Subfolders". Если установлен флажок, тогда поиск производится не только в указанной вами папке, но и во всех вложенных в нее папках.

- Поле ввода пути к папке, в которой осуществляется поиск файлов.

- Кнопка вызова диалогового окна выбора пути для выбора вами папки, в которой осуществляется поиск файлов.

- Кнопка "Старт" - начало процесса поиска файлов.

- Кнопка "Стоп" - прерывание процесса поиска файлов.

Кнопка [image] - добавляет все отмеченные строки (у которых установлены флажки) в список воспроизведения, который был текущим в момент открытия окна поиска и добавления файлов.

Кнопка [image] Создать новый - Создается новый пустой список воспроизведения и в него добавляются все отмеченные строки (у которых установлены флажки).


win_copy

Окно копирования файлов списка

Список воспроизведения может содержать ссылки на звуковые файлы, расположенные в различных папках вашего жесткого диска или даже на различных дисках, если их несколько в вашей системе. Функция копирования файлов списка в одну папку поможет скопировать или переместить файлы, на которые ссылаются записи текущего списка, в какую-либо одну папку.

Для того, чтобы файлы были скопированы или перемещены, необходимо их отметить. Для того, чтобы отметьить файлы в списке, установите поле статуса в соответствующих строках списка.

окно выбора дискаокно выборо папкиФайлы в текущей папкеввод имени создаваемой папкивыбор режима - скопировать или переместитьстарт обработки файловПрерывание обрпботки файловиндикация хода процессавыход из этого окнакнопка создания папки

Для того чтобы скопировать или переместить файлы, ссылки на которые содержатся в текущем списке:

1. Если вы хотите обработать ВСЕ строки списка, то отметьте ВСЕ файлы, установив поле статуса для всех строк (Ctrl+J). Если вы хотите выбрать несколько строк для обработки, то установите поле статуса у желаемых строк (щелчок левой кнопки мышки на строке, одновременно удерживая нажатой клавишу Alt).

2. Войдите в окно копирования файлов списка (Shift+F5).

3. Выберите диск и папку, в которую вы хотите скопировать или переместить файлы.

4. Вы можете создать новую папку. Для этого в сроке редактирования под надписью "создать папку" введите имя новой папки, а затем нажмите кнопку "Создать". Будет создана новая папка.

5. Выберите режим "Копировать" или "Переместить", затем нажмите кнопку "Старт". Если вы выбрали режим копированя, то файлы будут скопированы в выбранную папку. При этом текущий список останется без изменений. Если вы выбрали "Переместить", то файлы будут перемещены в выбранную папку (скопированы и удалены из исходных папок). При этом те строки списка, файлы которых были перемещены, будут изменены таким образом, что будут содержать ссылки на перемещенные файлы в их новом расположении. После завершения операции программа напомит вам, что список был изменен и для сохранения корректности ссылок необходимо сохранить список.

Примечание: Если в процессе копирования/перемещения файлов в папке - приемнике встрериться файл с именем, аналогичным копируемому, то такой файл (или файлы) будет заменен без предупреждения!


win_pocket

Окно Кармана

Очистить карманУдалить строкувставить строкувставить всепрослушать файлсписок строк карманастрока состояния кармана

Карман (Pocket) - это буфер обмена программы Lppro. Вы можете копировать в карман строки из одного и вставлять их в другой список воспроизведения (либо в тот же самый список воспроизведения). Обмен информацией через карман в среде LPPro возможен только между списками воспроизведения.

Окно кармана обеспечивает визуальный доступ к информации внутри кармана. Однако, для работы с карманом (обмен информацией между списками) совсем не обязательно открывать (делать видимым) окно кармана.

Вы можете перетаксивать мышкой строки из списка в окно кармана (с одновременным нажатием клавиши Ctrl) и из окна кармана в окно любого списка (без нажатия клавиши Ctrl).

Копирование в карман и вставка из кармана

Для того, чтобы скопировать строки из списка:
- выделить одну или несколько строк в списке воспроизведения.
- Нажать на клавиатуре Ctrl+C. выделенные строки будут скопированы в карман или:
- Щелкнуть правой кнопкой мышки на области окна списка воспроизведения и в контекстном меню выбрать пункт "Скопировать в карман", или:
- В главном меню программы выбрать пункт Редактирование [image] Скопировать в карман.
- Если вы хотите вырезать строки из списка, то нажмите Ctrl+X. Строки будут стерты в списке и помещены в карман.

Для того, чтобы вставить строки из кармана в список воспроизведения:
- Сделать активным окно списка. в который вы хотите вставить информацию из кармана.
- Нажать на клавиатуре сочетание клавиш Ctrl+V или:
- Щелкнуть правой кнопкой мышки на области окна списка воспроизведения и в контекстном меню выбрать пункт "Вставить из кармана", или
- В главном меню программы выбрать пункт Редактирование [image] Вставить из кармана.

- Вставка строк из кармана в список воспроизведения производится либо в позицию курсора, либо в строку, ниже позиции курсора в списке. Это зависит от режима работы кармана (см. далее)

Режимы работы кармана LPPro.

В отличие от буфера обмена Windows, карман LPPro имеет несколько режимов работы. Изменить режим работы кармана можно из главного меню (Редактиование [image] Режим работы кармана... ) или из окна настроек.

Режимы работы:

1. "Очищать карман при копировании и вырезании".

Если включен этот режим, то при помещении в карман информации он ведет себя аналогично буферу обмена Windows, то есть информация, находящаяся в кармане в момент помещения в него новой информации, стирается и заменяется новой. Предположим, что вы выделили и скопировали в карман одновременно 5 строк из списка воспроизведения. Затем вы копируете в карман еще одну строку. В итоге в кармане будет только одна строка, та, которую вы поместили туда последней.
Если этот режим отключен, то при помещении информации в карман предыдущая информация стираться не будет, а новые строки будут добавляться к уже имеющимся в кармане. Таким образом, в данном режиме вы можете накапливать строки в кармане, копируя их из разных списков или из одного списка.

2. "Очищать карман при вставке в список".
Если этот режим включен , то карман будет очищаться каждый раз, когда вы вставляете информацию из него в список воспроизведения.
Если этот режим отключен, то при вставке в список из кармана, информация в кармане не стирается. Вы можете копировать из кармана в список одну и ту же информацию много раз подряд.

2. "Вставлять в список в позицию ниже выделенной".
 Если этот режим включен, то при вставке из кармана в список воспроизведения, строки будут вставляться в позицию, на одну строку ниже курсора (выделенной строки). На рисунке эта позиция обведена красным:

Еслм этот режим выключен, то строки будут вставляться начиная с позиции курсора:

- Нажав на эту кнопку вы можете прослушать файл в строке кармана через проигрыватель подслушки (Двойной щелчок на строке в кармане приведет к тому же результату).

- Нажав на эту кнопку, вы можете вставить в текущий список все строки из кармана.

- Всавить в текущий список только одну строку из кармана (выделенную строку).

- удалить из кармана текущую строку (только одну)

- Очистить карман - удалить все строки

Область списка строк кармана. Двойной щелчок на какой-либо строке приведет к проигрыванию файла в проигрывателе подслушки.

- строка состояния окна кармана. В первом поле выводится количество строк в кармане, во втором поле - суммарное время звучания всех песен в кармане.


win_print

Окно печати и экспорта списка

Окно печати и экспорта списка позволяет распечатать список воспроизведения на принтере, или зкспортировать содержимое списка в виде текстового файла или в формате html.

Для печати списка необходимо выполнить следующие действия:

1. Находясь в текущем списке воспроизведения, нажмите на клавиатуре Ctrl+P (Или кнопку [image] на панели инструментов главного окна). Откроется данное окно печати и экспорта.

2. В поле "Название" введите название списка. Оно будет распечатано как заголовок списка. По умолчанию, после открытия окна печати и экспорта, в это поле подставляется имя файла списка воспроизведения.

3. В области "Включать поля" отметьте галочкой те поля, которые вы хотели бы включить в распечатку или экспортируемый файл.

- Номера строк - перед каждой строкой будет впечатываться ее порядковый номер.
- Номера страниц - В начале каждой страницы распечатки будет напечатан порядковый номер страницы.
- Имя файла - Будет напечатано имя файла песни.
- Название - Будет распечатано содержимое поля названия песни.
- Исполнитель - Будет распечатано содержимое поля исполнителя песни.
- Темп - Будет распечатано содержимое поля темпа песни.
- Время - Будет распечата продолжительность звучания песни.
- Громкость - Будет распечатано содержимое скрытого поля громкости песни.
- Время КФ - Будет распечатано содержимое скрытого поля времени кроссфейда песни.
- Статус - Будет распечатано содержимое поля статуса песни.
- Линия-разделитель - В распечатке информация, соответствующая каждой отдельной песни будет отделяться от других линией - разделителем.

4. Если вы хотите изменить какие-либо параметры принтера, вы можете это сделать, нажав кнопку "Настройки Принтера".

5. В поле "Отступ слева" введите нужное число. Отступ слева (ширина левого поля) устанавливается в миллиметрах. По умолчанию отступ слева равен 15 мм.

6. Нажмите кнопку Печать...

Для экспорта списка необходимо выполнить следующие действия:

Выполните шаги 1...3, как указано выше для печати списка.

4. В графе "Типы файлов для экспорта" выберите формат файла. Возможен формат текстовых файлов *.txt и формат html-файлов *.htm.

5. Нажмите кнопку "Экспорт". В открывшемся диалоговом окне сохранения файла задайте имя файла и папку его расположения.


Id3 tags

ID3-Тэги (ID3 tags)

Звуковые файлы распространенного формата Mp3 имеют некоторую служебную информационную область, в которой может быть сохранена различная информация о файле. Эта область назвается ID3-тэгами, илм просто Тэгами (tags). В тэгах может быть созранена информация о названии песни, исполнителе, годе выхода, альбоме, номере дорожки в альбоме, музыкальном стиле песни, а также комментарии. Многие Mp3 - проигрыватели (как программные, так и "железные") используют тэги для показа информации о песне.

В программе Live Performance Pro используются следующие Id3-тэги:

Title - Связан с полем "Название" списка воспроизведения. При добавлении в список песни из этого тэга извлекается информация и помещается в поле "Название". Если в тэге Title файла ничего не записано, то в поле "Название" помещается имя файла.

Artist - Связан с полем "Исполнитель" списка воспроизведения. При добавлении в список песни отсюда извлекается информация и помещается в поле "Исполнитель". Если в тэге Artist файла ничего не записано, то поле "Исполнитель" остается незаполненным.

Track - Связан с полем "Темп" списка воспроизведения. При выполнении операции "Переписать Тэги mp3 файлов списка" в этот тэг записывается значение темпа песни.

Остальные тэги непосредственно не используются, хотя и могут быть изменены из окна информации о файле.

<<вернуться


main_statusbar

Строка состояния программы.

Слева направо в 4-х прямоугольных областях отображаются:

1. Количество строк, номер текущей строки, время звучания текущей песни или, если выделено несколько строк, то сумаррное время их звучания.

2. Суммарное время звучания всего списка

3. Если список был измнен, то в этом прямоугольнике отображается слово "Modified". Иначе прямоугольник пустой.

4. Название песни, загруженной в виртуальный микшер (основное устройство). Есои в списке не задано название песни, то отображается имя файла.


main_volume

Регулятор общей громкости основного устройства.

максимальная громкость - 100 едениц. Вы можете изменять громкость с клавиатуры шагами по 2 еденицы, нажимая клавиши < и > или на дополнительной клавиатуре клавиши + и -

<<Вернуться